aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-04-25 23:34:31 -0400
committerHorea Christian <chr@chymera.eu>2022-04-25 23:34:31 -0400
commit79004b03e341bd74e25e1b3e021d8da672abc630 (patch)
tree954efa81f83fc5084dbadb83b44de0975ea22e8a /dev-python/llvmlite/llvmlite-0.38.0.ebuild
parentsci-biology/samri: renamed dependency (diff)
downloadsci-79004b03e341bd74e25e1b3e021d8da672abc630.tar.gz
sci-79004b03e341bd74e25e1b3e021d8da672abc630.tar.bz2
sci-79004b03e341bd74e25e1b3e021d8da672abc630.zip
dev-python/llvmlite: LLVM_MAX_SLOT bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/llvmlite/llvmlite-0.38.0.ebuild')
-rw-r--r--dev-python/llvmlite/llvmlite-0.38.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/llvmlite/llvmlite-0.38.0.ebuild b/dev-python/llvmlite/llvmlite-0.38.0.ebuild
deleted file mode 100644
index cadbc5407..000000000
--- a/dev-python/llvmlite/llvmlite-0.38.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S="${WORKDIR}/${P/_/}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="examples"
-
-LLVM_MAX_SLOT=11
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- sed -i -e '/max_python/s:3\.10:3.11:' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}