aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-12-22 11:41:05 +0100
committerJustin Lecher <jlec@gentoo.org>2016-12-22 10:41:05 +0000
commit27cf8577e55d9b235071de97070ea60db12c5a28 (patch)
treef0f278c6d5c1c7961b72cfc48dfdc256547a2856 /dev-python/matplotlib-venn
parentBru2nii (#715) (diff)
downloadsci-27cf8577e55d9b235071de97070ea60db12c5a28.tar.gz
sci-27cf8577e55d9b235071de97070ea60db12c5a28.tar.bz2
sci-27cf8577e55d9b235071de97070ea60db12c5a28.zip
dev-python/matplotlib-venn: enabled test phase (#710)
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-python/matplotlib-venn')
-rw-r--r--dev-python/matplotlib-venn/matplotlib-venn-0.11.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/matplotlib-venn/matplotlib-venn-0.11.ebuild b/dev-python/matplotlib-venn/matplotlib-venn-0.11.ebuild
index bdb4ed2a6..272e5d207 100644
--- a/dev-python/matplotlib-venn/matplotlib-venn-0.11.ebuild
+++ b/dev-python/matplotlib-venn/matplotlib-venn-0.11.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_4 python3_5)
inherit distutils-r1
@@ -15,10 +15,17 @@ SRC_URI="mirror://pypi/m/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test --verbose || die
+}