aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-10 17:36:50 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-10 17:36:50 +0000
commit200bea55252826e6c578cdd1ea0f4048b313f89e (patch)
treecace5bb844e319dffc195d9291758b4c37791912 /dev-python/matplotlib/matplotlib-0.87.1.ebuild
parentadded numpy/ChangeLog (diff)
downloadsci-200bea55252826e6c578cdd1ea0f4048b313f89e.tar.gz
sci-200bea55252826e6c578cdd1ea0f4048b313f89e.tar.bz2
sci-200bea55252826e6c578cdd1ea0f4048b313f89e.zip
matplotlib-0.87.1 version bump and doc clean
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@116 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-python/matplotlib/matplotlib-0.87.1.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-0.87.1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/matplotlib/matplotlib-0.87.1.ebuild b/dev-python/matplotlib/matplotlib-0.87.1.ebuild
new file mode 100644
index 000000000..977c39198
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.87.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils python
+
+DESCRIPTION="Python plotting library with Matlab like syntax"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+mplot3d? http://matplotlib.sourceforge.net/mpl3d.zip
+doc? http://matplotlib.sourceforge.net/users_guide_${PV}.pdf"
+
+IUSE="doc gtk tcltk mplot3d"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="PYTHON"
+
+DEPEND="virtual/python
+ || (
+ >=dev-python/numeric-22
+ dev-python/numarray
+ dev-python/numpy
+ )
+ >=media-libs/freetype-2.1.7
+ media-libs/libpng
+ sys-libs/zlib
+ gtk? ( >=dev-python/pygtk-1.99.16 )
+ dev-python/pytz
+ dev-python/python-dateutil"
+
+
+pkg_setup() {
+ if use tcltk; then
+ python_tkinter_exists
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # disable autodetection, rely on USE instead
+ epatch "${FILESDIR}/${PN}-0.87-no-autodetect.patch"
+ sed -i \
+ -e "/^BUILD_GTK/s/'auto'/$(use gtk && echo 1 || echo 0)/" \
+ -e "/^BUILD_WX/s/'auto'/0/" \
+ -e "/^BUILD_TK/s/'auto'/$(use tcltk && echo 1 || echo 0)/" \
+ setup.py
+
+ # patch to apply for mplot3d
+ # http://www.scipy.org/Cookbook/Matplotlib/mplot3D
+ if use mplot3d; then
+ cd ${WORKDIR}/3d
+ epatch "${FILESDIR}/${PN}-0.87-mplot3d.patch"
+ fi
+
+}
+
+src_install() {
+ distutils_src_install
+
+ use mplot3d && cp -r ${WORKDIR}/3d \
+ ${D}/usr/$(get_libdir)/python2.4/site-packages/mpl3d
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinto /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ insinto /usr/share/doc/${PF}/
+ doins ${DISTDIR}/users_guide_*.pdf
+ fi
+}