aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-22 14:57:23 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-04-22 14:57:23 +0000
commit16bbb89d9541f4d7d010f3b0a28b0bfce0030d39 (patch)
treea5743f7117fac3c052c78c8dd8653511cd92c36d /dev-python/matplotlib
parentopenmpi: fixed digest (diff)
downloadsci-16bbb89d9541f4d7d010f3b0a28b0bfce0030d39.tar.gz
sci-16bbb89d9541f4d7d010f3b0a28b0bfce0030d39.tar.bz2
sci-16bbb89d9541f4d7d010f3b0a28b0bfce0030d39.zip
matplotlib-0.87.2-r2: added agg support
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@181 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest2
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.87.2-r23
-rw-r--r--dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild76
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 8fb198822..fa640b3ed 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,6 +1,8 @@
MD5 917df696332bf92ed0d12474dcc04944 ChangeLog 4080
MD5 164457a27c959174cc2933d826190f3d files/digest-matplotlib-0.87.2-r1 192
+MD5 164457a27c959174cc2933d826190f3d files/digest-matplotlib-0.87.2-r2 192
MD5 bf815cadfdb2159e83dffd0862545458 files/matplotlib-0.87.2-no-autodetect.patch 1817
MD5 802d475da9c3232949f87351fd10847b files/matplotlib-mplot3d.patch 918
MD5 bdf28f13337a15989272fbffc517c0dc matplotlib-0.87.2-r1.ebuild 1782
+MD5 1c99d1b270e2e57337f764f6edd6a0bf matplotlib-0.87.2-r2.ebuild 1878
MD5 7d1fbbf5496138b3b2f2f07ec757fecb metadata.xml 428
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r2 b/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r2
new file mode 100644
index 000000000..c293c85ba
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.87.2-r2
@@ -0,0 +1,3 @@
+MD5 74dde3c3e33797f56ebd6ca578090f8e matplotlib-0.87.2.tar.gz 2655790
+MD5 41884cf53ede9a635b6ecc08dd2bd6fc mpl3d.zip 179714
+MD5 bcc272707e7db06b8a3aab36c6317e03 users_guide_0.87.1.pdf 4675932
diff --git a/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild b/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild
new file mode 100644
index 000000000..c79dc96a0
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.87.2-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils python
+
+DESCRIPTION="Python plotting library with Matlab like syntax"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mplot3d? http://matplotlib.sourceforge.net/mpl3d.zip
+ doc? http://matplotlib.sourceforge.net/users_guide_0.87.1.pdf"
+
+IUSE="doc gtk tcltk wxpython mplot3d agg"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="PYTHON"
+
+DEPEND="virtual/python
+ || (
+ >=dev-python/numeric-22
+ dev-python/numarray
+ dev-python/numpy
+ )
+ >=media-libs/freetype-2.1.7
+ media-libs/libpng
+ sys-libs/zlib
+ gtk? ( >=dev-python/pygtk-1.99.16 )
+ wxpython? ( dev-python/wxpython )
+ dev-python/pytz
+ dev-python/python-dateutil
+ agg? ( x11-libs/agg )"
+
+pkg_setup() {
+ if use tcltk; then
+ python_tkinter_exists
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # disable autodetection, rely on USE instead
+ epatch "${FILESDIR}/${PN}-0.87.2-no-autodetect.patch"
+ sed -i \
+ -e "/^BUILD_GTK/s/'auto'/$(use gtk && echo 1 || echo 0)/g" \
+ -e "/^BUILD_WX/s/'auto'/$(use wxpython && echo 1 || echo 0)/g" \
+ -e "/^BUILD_TK/s/'auto'/$(use tcltk && echo 1 || echo 0)/g" \
+ -e "/^BUILD_AGG/s/'auto'/$(use agg && echo 1 || echo 0)/g" \
+ setup.py
+
+ # patch to apply for mplot3d
+ # http://www.scipy.org/Cookbook/Matplotlib/mplot3D
+ if use mplot3d; then
+ cd ${WORKDIR}/3d
+ epatch "${FILESDIR}/${PN}-mplot3d.patch"
+ fi
+
+}
+
+src_install() {
+ distutils_src_install
+
+ use mplot3d && cp -r ${WORKDIR}/3d \
+ ${D}/usr/$(get_libdir)/python2.4/site-packages/mpl3d
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinto /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ insinto /usr/share/doc/${PF}/
+ doins ${DISTDIR}/users_guide_*.pdf
+ fi
+}