aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-02 13:40:30 +0100
committerHorea Christian <chr@chymera.eu>2021-01-02 23:30:26 -0500
commit42f7255665aedfc21ca5bbbffcd6fa9c74842cc2 (patch)
treed992d27a940fc1c9829fe53fa26d313221a87cf3 /dev-python/matrix2latex
parentdev-python/dijitso: bump python targets, enbale tests (diff)
downloadsci-42f7255665aedfc21ca5bbbffcd6fa9c74842cc2.tar.gz
sci-42f7255665aedfc21ca5bbbffcd6fa9c74842cc2.tar.bz2
sci-42f7255665aedfc21ca5bbbffcd6fa9c74842cc2.zip
dev-python/matrix2latex: bump python targets, enable tests and sphinx
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/matrix2latex')
-rw-r--r--dev-python/matrix2latex/Manifest2
-rw-r--r--dev-python/matrix2latex/matrix2latex-1.0.0.ebuild19
-rw-r--r--dev-python/matrix2latex/matrix2latex-1.9_p20160719.ebuild30
3 files changed, 31 insertions, 20 deletions
diff --git a/dev-python/matrix2latex/Manifest b/dev-python/matrix2latex/Manifest
index a59826c27..d6ba7d29c 100644
--- a/dev-python/matrix2latex/Manifest
+++ b/dev-python/matrix2latex/Manifest
@@ -1 +1 @@
-DIST matrix2latex-1.0.0.tar.gz 183350 BLAKE2B daae91c8b91e9b21fdf62a1c6936a20390988ea1b6f2d4b6a2c34c14441b25274b1b3f4cd907311d52340dde7deb962bacded06b2a459f98e21a8e07777f3730 SHA512 fd116bba7a40303851ceb7d63b55545b9345cc5721e2d33350ca167f0752bc47f802ebfa5d3794fe45148f08a6005e64fb569f0d60072a4ac3edaf9a42bb1ce0
+DIST matrix2latex-1.9_p20160719.tar.gz 594099 BLAKE2B 071c903a4b56d99aeaf67e0bed59f97d0fc9f3358fdd778ba79aedeef77d47fc2af61b7ec7d4397442c2f155374484efcf4c9c51992739601d1e26e6dcbc38c5 SHA512 c48186e42b5ec247574d2aa06ff610b80efdb6e828a8c1bcd13861b459bc1ae1176088c44111d839d16652059b350ad61db55a105ae22abc4fd6b0d1eaa3def9
diff --git a/dev-python/matrix2latex/matrix2latex-1.0.0.ebuild b/dev-python/matrix2latex/matrix2latex-1.0.0.ebuild
deleted file mode 100644
index 502c649fc..000000000
--- a/dev-python/matrix2latex/matrix2latex-1.0.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6..9}} )
-
-inherit distutils-r1 multilib
-
-DESCRIPTION="A tool to create LaTeX tables from python lists and arrays"
-HOMEPAGE="https://github.com/TheChymera/matrix2latex"
-SRC_URI="https://github.com/TheChymera/${PN}/blob/master/archive/${PN}Python-${PV}.tar.gz?raw=true -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-S="${WORKDIR}/${PN}Python${PV}"
diff --git a/dev-python/matrix2latex/matrix2latex-1.9_p20160719.ebuild b/dev-python/matrix2latex/matrix2latex-1.9_p20160719.ebuild
new file mode 100644
index 000000000..14a2ecaa7
--- /dev/null
+++ b/dev-python/matrix2latex/matrix2latex-1.9_p20160719.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+COMMIT="78edec90115b855cb743ecc702d252514dedc6db"
+
+DESCRIPTION="A tool to create LaTeX tables from python lists and arrays"
+HOMEPAGE="https://github.com/TheChymera/matrix2latex"
+SRC_URI="https://github.com/TheChymera/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+distutils_enable_sphinx doc_sphinx
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # this has been renamed in newer versions of sphinx
+ sed -i -e 's/sphinx.ext.pngmath/sphinx.ext.imgmath/g' doc_sphinx/conf.py
+
+ distutils-r1_python_prepare_all
+}