aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2021-01-02 23:53:37 -0500
committerHorea Christian <chr@chymera.eu>2021-01-02 23:53:37 -0500
commitaf6f8867c50b39b6857def4a3f528fe78cc350fd (patch)
tree925f08ca1fa33bb4efd54254777891c07d369633 /dev-python/matrix2latex
parentdev-python/viper: remove package, py2 only, no longer in development (diff)
downloadsci-af6f8867c50b39b6857def4a3f528fe78cc350fd.tar.gz
sci-af6f8867c50b39b6857def4a3f528fe78cc350fd.tar.bz2
sci-af6f8867c50b39b6857def4a3f528fe78cc350fd.zip
dev-python/matrix2latex: version bump 1.10
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/matrix2latex')
-rw-r--r--dev-python/matrix2latex/Manifest1
-rw-r--r--dev-python/matrix2latex/matrix2latex-1.10.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/matrix2latex/Manifest b/dev-python/matrix2latex/Manifest
index d6ba7d29c..b80d89969 100644
--- a/dev-python/matrix2latex/Manifest
+++ b/dev-python/matrix2latex/Manifest
@@ -1 +1,2 @@
+DIST matrix2latex-1.10.tar.gz 594004 BLAKE2B 0950af176071470781f45a37955ce4222299c0cae276ea7b0b767d372b3c5fc1eff4f67c26d3702dd0bc2a06c8eca5569e8fbb67b247c0bba698df2bdf8a762a SHA512 61570aa8dbb396b1c33fd327acae67b1c5b7c1655a60ad73da0ed01627c569f88f318aec92cbef1df25fc2da6e68ecf38fb1a94d26777bd50caffa694f587efe
DIST matrix2latex-1.9_p20160719.tar.gz 594099 BLAKE2B 071c903a4b56d99aeaf67e0bed59f97d0fc9f3358fdd778ba79aedeef77d47fc2af61b7ec7d4397442c2f155374484efcf4c9c51992739601d1e26e6dcbc38c5 SHA512 c48186e42b5ec247574d2aa06ff610b80efdb6e828a8c1bcd13861b459bc1ae1176088c44111d839d16652059b350ad61db55a105ae22abc4fd6b0d1eaa3def9
diff --git a/dev-python/matrix2latex/matrix2latex-1.10.ebuild b/dev-python/matrix2latex/matrix2latex-1.10.ebuild
new file mode 100644
index 000000000..0d84ff9e9
--- /dev/null
+++ b/dev-python/matrix2latex/matrix2latex-1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to create LaTeX tables from python lists and arrays"
+HOMEPAGE="https://github.com/TheChymera/matrix2latex"
+SRC_URI="https://github.com/TheChymera/matrix2latex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+distutils_enable_sphinx doc_sphinx
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # this has been renamed in newer versions of sphinx
+ sed -i -e 's/sphinx.ext.pngmath/sphinx.ext.imgmath/g' doc_sphinx/conf.py
+
+ distutils-r1_python_prepare_all
+}