aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-14 12:06:41 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-14 12:06:41 +0200
commitde09b4475e0bd85126040c64e64abd0efe29b2c2 (patch)
tree65cec9a857d1abf0d73dbf9334957b548321535b /dev-python/meshpy/meshpy-2013.1.2.ebuild
parentdev-python/instant: Version Bump; Bump to EAPI=5 and distutils-r1.eclass (diff)
downloadsci-de09b4475e0bd85126040c64e64abd0efe29b2c2.tar.gz
sci-de09b4475e0bd85126040c64e64abd0efe29b2c2.tar.bz2
sci-de09b4475e0bd85126040c64e64abd0efe29b2c2.zip
dev-python/meshpy: Version Bump; Bump to EAPI=5 and distutils-r1.eclass
Package-Manager: portage-2.2.0_alpha179 RepoMan-Options: --force
Diffstat (limited to 'dev-python/meshpy/meshpy-2013.1.2.ebuild')
-rw-r--r--dev-python/meshpy/meshpy-2013.1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/meshpy/meshpy-2013.1.2.ebuild b/dev-python/meshpy/meshpy-2013.1.2.ebuild
new file mode 100644
index 000000000..6d76c3874
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2013.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="MeshPy"
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="http://mathema.tician.de/software/meshpy http://pypi.python.org/pypi/MeshPy"
+SRC_URI="mirror://pypi/M/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/pyvtk[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ sed 's: delay = 10: delay = 1:g' -i aksetup_helper.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ mkdir "${BUILD_DIR}" || die
+ echo "BOOST_PYTHON_LIBNAME = [\'boost_${EPYTHON}-mt\']">> "${BUILD_DIR}"/siteconf.py
+ distutils-r1_python_compile
+}