aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:43:15 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:43:15 +0100
commit47ec47ad369cea635ea848b7925ebccace8d58a7 (patch)
tree49e1eef77f018181313683afedd303ac98a0cd12 /dev-python/nbconvert
parentdev-python/nbformat: Moved to tree (diff)
downloadsci-47ec47ad369cea635ea848b7925ebccace8d58a7.tar.gz
sci-47ec47ad369cea635ea848b7925ebccace8d58a7.tar.bz2
sci-47ec47ad369cea635ea848b7925ebccace8d58a7.zip
dev-python/nbconvert: Moved to tree
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/ChangeLog4
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild79
-rw-r--r--dev-python/nbconvert/nbconvert-4.1.0.ebuild78
4 files changed, 4 insertions, 159 deletions
diff --git a/dev-python/nbconvert/ChangeLog b/dev-python/nbconvert/ChangeLog
index ca549aa0f..b03b909e7 100644
--- a/dev-python/nbconvert/ChangeLog
+++ b/dev-python/nbconvert/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 28 Nov 2015; Marius Brehler <marbre@linux.sungazer.de> -Manifest,
+ -nbconvert-4.0.0-r1.ebuild, -nbconvert-4.1.0.ebuild:
+ dev-python/nbconvert: Moved to tree
+
22 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> nbconvert-9999.ebuild:
dev-python/nbconvert: Add ~x86 to KEYWORDS, fixes #561032
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
deleted file mode 100644
index e1ad5fef7..000000000
--- a/dev-python/nbconvert/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST nbconvert-4.0.0.tar.gz 260424 SHA256 472ad15d1a71f1ef00c4094c11bb93638858fc89fb2c5838b3aa6b67d981b437 SHA512 0f495d75121815282ffe9f67ebf0818ca09790e2d8745e04635c368932d11db07a07d91410b81366a29d3d17ffb98b1ac1bbae18268d448ba494ca2685ec85e6 WHIRLPOOL 1de760f6fc5392fa0dd50834fbf8417c5c3389f904724ba3c4d68df24e44ed84789256193c2fb625527caec2f45893f521e9f86de64a8e3686beef6fb824386e
-DIST nbconvert-4.1.0.tar.gz 263948 SHA256 e0296e45293dd127d028f678e3b6aba3f1db3283a134178bdb49eea402d4cf1c SHA512 9761cf8cdf206bd8f27c666d7b520cbd7d805353cf46b212b46ee6053b47ec6728a5926dfe59acef109c8770580c41d51aa5b943a27e72bccecc68a7d7b68bfb WHIRLPOOL 9cc27a45b00ee9914674cd14a279be1691eb8a8538803bdda127513f56dd0ce53b10745f305f8fb82abd2d19efe7c1b0284bf05f8088360d2def6c97db0c1c6e
diff --git a/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild b/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild
deleted file mode 100644
index ddbb31e64..000000000
--- a/dev-python/nbconvert/nbconvert-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-MY_PN="nbconvert"
-
-DESCRIPTION="Converting Jupyter Notebooks"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-PATCHES=(
- "${FILESDIR}/${P}"-docs-Makefile.patch
- "${FILESDIR}/${P}"-pandoc-highlighting.patch
-)
-
-RDEPEND="
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/mistune[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- app-text/pandoc
- )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- nosetests --with-coverage --cover-package=nbconvert nbconvert || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if ! has_version app-text/pandoc ; then
- einfo "Pandoc is required for converting to formats other than Python,"
- einfo "HTML, and Markdown. If you need this functionality, install"
- einfo "app-text/pandoc."
- fi
-}
diff --git a/dev-python/nbconvert/nbconvert-4.1.0.ebuild b/dev-python/nbconvert/nbconvert-4.1.0.ebuild
deleted file mode 100644
index 0eab8bc2a..000000000
--- a/dev-python/nbconvert/nbconvert-4.1.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-MY_PN="nbconvert"
-
-DESCRIPTION="Converting Jupyter Notebooks"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0.0-docs-Makefile.patch
-)
-
-RDEPEND="
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/mistune[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- app-text/pandoc
- )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- nosetests --with-coverage --cover-package=nbconvert nbconvert || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if ! has_version app-text/pandoc ; then
- einfo "Pandoc is required for converting to formats other than Python,"
- einfo "HTML, and Markdown. If you need this functionality, install"
- einfo "app-text/pandoc."
- fi
-}