aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-21 19:39:58 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-21 19:40:10 -0400
commitcff5710de6fd6df9a8300da5e12c9ead2e216f10 (patch)
tree856c5ff5ad90dc589ea05b899ea9dd13be98d58f /dev-python/nbformat/nbformat-9999.ebuild
parentdev-python/nbdime: drop package (diff)
downloadsci-cff5710de6fd6df9a8300da5e12c9ead2e216f10.tar.gz
sci-cff5710de6fd6df9a8300da5e12c9ead2e216f10.tar.bz2
sci-cff5710de6fd6df9a8300da5e12c9ead2e216f10.zip
dev-python/nbformat: drop package
present in ::gentoo Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/nbformat/nbformat-9999.ebuild')
-rw-r--r--dev-python/nbformat/nbformat-9999.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/nbformat/nbformat-9999.ebuild b/dev-python/nbformat/nbformat-9999.ebuild
deleted file mode 100644
index 9549f6909..000000000
--- a/dev-python/nbformat/nbformat-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE='sqlite'
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Reference implementation of the Jupyter Notebook format"
-HOMEPAGE="http://jupyter.org"
-EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/testpath[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- py.test -v --cov nbformat nbformat || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}