aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:42:36 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-28 18:42:36 +0100
commit58456081c070a9e3c3fc061679c1a4ba69f3e37f (patch)
treedfb5ff3f1f90d803ab9da8685f7fdf7b416da734 /dev-python/nbformat
parentLarge fix of numeric code (diff)
downloadsci-58456081c070a9e3c3fc061679c1a4ba69f3e37f.tar.gz
sci-58456081c070a9e3c3fc061679c1a4ba69f3e37f.tar.bz2
sci-58456081c070a9e3c3fc061679c1a4ba69f3e37f.zip
dev-python/nbformat: Moved to tree
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/ChangeLog4
-rw-r--r--dev-python/nbformat/Manifest2
-rw-r--r--dev-python/nbformat/nbformat-4.0.0.ebuild59
-rw-r--r--dev-python/nbformat/nbformat-4.0.1.ebuild60
4 files changed, 4 insertions, 121 deletions
diff --git a/dev-python/nbformat/ChangeLog b/dev-python/nbformat/ChangeLog
index 934c6c23a..0374cbb0a 100644
--- a/dev-python/nbformat/ChangeLog
+++ b/dev-python/nbformat/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 28 Nov 2015; Marius Brehler <marbre@linux.sungazer.de> -Manifest,
+ -nbformat-4.0.0.ebuild, -nbformat-4.0.1.ebuild:
+ dev-python/nbformat: Moved to tree
+
*nbformat-4.0.1 (06 Oct 2015)
06 Oct 2015; Marius Brehler <marbre@linux.sungazer.de> +nbformat-4.0.1.ebuild:
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
deleted file mode 100644
index 847b7d3b2..000000000
--- a/dev-python/nbformat/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST nbformat-4.0.0.tar.gz 106427 SHA256 daf9b990e96863d120aff123361156a316757757b81a8070eb6945e4a9774b2d SHA512 60d690ecd8ab9d5712a1dfc26cbf8aded22000f167afe581842720905b8a97ce71bebeb9e0133be5eadc0975563a9dcf6d9302075308461fd2b3e087b3ff94fa WHIRLPOOL 9210fc1278153d65610d396e0b889111ad083ef2667a05fb4faec268ee64762530ebeb60543f1b493eb25c52d7641cba6c620863780c0bb995537efef2f4bc74
-DIST nbformat-4.0.1.tar.gz 105767 SHA256 5261c957589b9dfcd387c338d59375162ba9ca82c69e378961a1f4e641285db5 SHA512 f73e8cffc61825aa8b7b0ef3b842cba51baf2cdf0c5d0035e2e7cb51f71c6c819f09201367a3b342c2736492dee1e78c519961aaea8f2cc4b5e69a1545085d2a WHIRLPOOL 9b08003c456e00c529b7bf8e786d57a583e53e5a1e7e9eb4c3cc492c5b1d60e76579c9102e6c56749d546a9a124d475687d4ec1d71e0f3634698d5e30499db93
diff --git a/dev-python/nbformat/nbformat-4.0.0.ebuild b/dev-python/nbformat/nbformat-4.0.0.ebuild
deleted file mode 100644
index cc116c0dd..000000000
--- a/dev-python/nbformat/nbformat-4.0.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
-PYTHON_REQ_USE='sqlite'
-
-inherit distutils-r1
-
-DESCRIPTION="Reference implementation of the Jupyter Notebook format"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- nosetests --with-coverage --cover-package=nbformat nbformat || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/nbformat/nbformat-4.0.1.ebuild b/dev-python/nbformat/nbformat-4.0.1.ebuild
deleted file mode 100644
index 449d99c5b..000000000
--- a/dev-python/nbformat/nbformat-4.0.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-PYTHON_REQ_USE='sqlite'
-
-inherit distutils-r1
-
-DESCRIPTION="Reference implementation of the Jupyter Notebook format"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- nosetests --with-coverage --cover-package=nbformat nbformat || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}