aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-01 16:21:06 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-01 16:21:06 +0000
commit17a24823709721d2361d335e0864d525fc076197 (patch)
tree6ae90e16c3fab2182ee2c1d204338f3df3865e3e /dev-python/numpy/numpy-0.9.8.ebuild
parentagg-2.4: updated for X modular (diff)
downloadsci-17a24823709721d2361d335e0864d525fc076197.tar.gz
sci-17a24823709721d2361d335e0864d525fc076197.tar.bz2
sci-17a24823709721d2361d335e0864d525fc076197.zip
numpy-0.9.8: version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@214 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-python/numpy/numpy-0.9.8.ebuild')
-rw-r--r--dev-python/numpy/numpy-0.9.8.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-0.9.8.ebuild b/dev-python/numpy/numpy-0.9.8.ebuild
new file mode 100644
index 000000000..1ffbfda2a
--- /dev/null
+++ b/dev-python/numpy/numpy-0.9.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Powerful N-dimensional array object and processing for Python."
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.scipy.org/"
+# temp fix force atlas, while eselect gets ready.
+DEPEND=">=dev-lang/python-2.3
+ lapack? ( sci-libs/blas-atlas )
+ lapack? ( sci-libs/lapack-atlas )"
+IUSE="lapack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # sed to patch ATLAS libraries names
+ sed -i \
+ -e "s:f77blas: blas:g" \
+ -e "s:'f77blas':'blas':g" \
+ numpy/distutils/system_info.py
+
+ #
+ export MKL=None
+ export BLAS=None
+ export LAPACK=None
+ export PTATLAS=None
+
+ if use lapack; then
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:" >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ fi
+ else
+ export ATLAS=None
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}