aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-05-20 22:15:31 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-05-20 22:15:31 +0000
commit8d7feade594163f735a9db8a7eeb9d024117a069 (patch)
tree1164edd065a93b2267a9c59bc0ce4266fcd5c605 /dev-python/persim/persim-0.3.0.ebuild
parentdev-python/kmapper: version bump to 2.0.1 (diff)
downloadsci-8d7feade594163f735a9db8a7eeb9d024117a069.tar.gz
sci-8d7feade594163f735a9db8a7eeb9d024117a069.tar.bz2
sci-8d7feade594163f735a9db8a7eeb9d024117a069.zip
dev-python/persim: version bump to 0.3.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/persim/persim-0.3.0.ebuild')
-rw-r--r--dev-python/persim/persim-0.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/persim/persim-0.3.0.ebuild b/dev-python/persim/persim-0.3.0.ebuild
new file mode 100644
index 000000000..79bdd7426
--- /dev/null
+++ b/dev-python/persim/persim-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distances and representations of persistence diagrams"
+HOMEPAGE="https://persim.scikit-tda.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/hopcroftkarp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ test? ( dev-python/deprecated[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest