aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-07 01:43:30 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-07 01:43:30 +0000
commit69bb7587050a5a4e68e7fcb64b69b7b75477cdf2 (patch)
tree7d61c05735f11a1401c908d0b24870ebbae5bffd /dev-python/python-vxi11
parentdev-python/pythoncgns: drop dead package (diff)
downloadsci-69bb7587050a5a4e68e7fcb64b69b7b75477cdf2.tar.gz
sci-69bb7587050a5a4e68e7fcb64b69b7b75477cdf2.tar.bz2
sci-69bb7587050a5a4e68e7fcb64b69b7b75477cdf2.zip
dev-python/python-vxi11: version bump to 0.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/python-vxi11')
-rw-r--r--dev-python/python-vxi11/Manifest1
-rw-r--r--dev-python/python-vxi11/python-vxi11-0.9.ebuild21
-rw-r--r--dev-python/python-vxi11/python-vxi11-9999.ebuild21
3 files changed, 36 insertions, 7 deletions
diff --git a/dev-python/python-vxi11/Manifest b/dev-python/python-vxi11/Manifest
index d2928e820..e9af1141f 100644
--- a/dev-python/python-vxi11/Manifest
+++ b/dev-python/python-vxi11/Manifest
@@ -1 +1,2 @@
DIST python-vxi11-0.8.tar.gz 19664 BLAKE2B 0bcdce1d1384ea1e40b71265a46fcf6f1c5e8cfbb947695c82a133edddf3b1b19d5c80b80b9a336c6ea16801949220a856f251f350346efaa71cee24ec8e4860 SHA512 fbd2bf54d161527135d7f7739cf3921f31173511da30078042c02dabc28ef61fafa296eb65d4908e0f6559fd08604c690c91e27564041186a4d7892940658f3f
+DIST python-vxi11-0.9.tar.gz 21446 BLAKE2B 33d5af56aabf6583f630f4b8d7e31fc8fb962ef8c6952cf1894a69a304cd2f2f0c3d1bc2c17000a5b029c977c8a7c782657c9d9fab7ced484e41514ab77432f5 SHA512 d3136ca8d6cdd7bc695d52ab2adbad956936de6ab99b4be58f3b11111b1f0afc8720239ef6754da79f1c719bbd2ccec1c8a58249a4408b8536b7fd387c0164d0
diff --git a/dev-python/python-vxi11/python-vxi11-0.9.ebuild b/dev-python/python-vxi11/python-vxi11-0.9.ebuild
new file mode 100644
index 000000000..fc6f73ae7
--- /dev/null
+++ b/dev-python/python-vxi11/python-vxi11-0.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Provides a pure Python VXI-11 driver for controlling instruments over Ethernet"
+HOMEPAGE="https://github.com/python-ivi/python-vxi11"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/python-ivi/python-vxi11"
+else
+ SRC_URI="https://github.com/python-ivi/python-vxi11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
diff --git a/dev-python/python-vxi11/python-vxi11-9999.ebuild b/dev-python/python-vxi11/python-vxi11-9999.ebuild
index f0da2f343..fc6f73ae7 100644
--- a/dev-python/python-vxi11/python-vxi11-9999.ebuild
+++ b/dev-python/python-vxi11/python-vxi11-9999.ebuild
@@ -1,14 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
-
-inherit distutils-r1 git-r3
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
DESCRIPTION="Provides a pure Python VXI-11 driver for controlling instruments over Ethernet"
HOMEPAGE="https://github.com/python-ivi/python-vxi11"
-EGIT_REPO_URI="https://github.com/python-ivi/${PN}.git git://github.com/python-ivi/${PN}.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/python-ivi/python-vxi11"
+else
+ SRC_URI="https://github.com/python-ivi/python-vxi11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
LICENSE="MIT"
-SLOT="0" \ No newline at end of file
+SLOT="0"