aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jon Booker <joe@neoturbine.net>2014-02-05 13:48:03 -0500
committerJoseph Jon Booker <joe@neoturbine.net>2014-02-05 13:48:03 -0500
commit66f47ae9db006d873ef61677b7a8894b23fb166f (patch)
tree48ea0b5f1a43c01fefd30ddd575a6c1e0cc6487a /dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild
parentMerge branch 'master' of github.com:gentoo-science/sci (diff)
downloadsci-66f47ae9db006d873ef61677b7a8894b23fb166f.tar.gz
sci-66f47ae9db006d873ef61677b7a8894b23fb166f.tar.bz2
sci-66f47ae9db006d873ef61677b7a8894b23fb166f.zip
dev-python/pywcsgrid2: Add ebuild for git version of pywcsgrid2
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild')
-rw-r--r--dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild b/dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild
new file mode 100644
index 000000000..5af182857
--- /dev/null
+++ b/dev-python/pywcsgrid2/pywcsgrid2-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Custom Matplotlib Axes class for displaying astronomical fits images"
+HOMEPAGE="http://leejjoon.github.io/pywcsgrid2/"
+EGIT_REPO_URI="https://github.com/leejjoon/pywcsgrid2.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ || ( dev-python/pyfits[${PYTHON_USEDEP}] dev-python/astropy[${PYTHON_USEDEP}] )
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ virtual/pywcs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"