aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-30 17:31:32 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 17:22:01 +0000
commitb0002ea0ee11d1934e3131f96b81383714a7d912 (patch)
tree43a4d8c9b0603a4e117dc8e745810c72cd7fd124 /dev-python/sphinxcontrib-napoleon
parentdev-python/sphinx-argparse: new dep, copy from ::guru (diff)
downloadsci-b0002ea0ee11d1934e3131f96b81383714a7d912.tar.gz
sci-b0002ea0ee11d1934e3131f96b81383714a7d912.tar.bz2
sci-b0002ea0ee11d1934e3131f96b81383714a7d912.zip
dev-python/sphinxcontrib-napoleon: new dep, copy from ::guru
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/sphinxcontrib-napoleon')
-rw-r--r--dev-python/sphinxcontrib-napoleon/Manifest1
-rw-r--r--dev-python/sphinxcontrib-napoleon/metadata.xml9
-rw-r--r--dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7.ebuild29
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-napoleon/Manifest b/dev-python/sphinxcontrib-napoleon/Manifest
new file mode 100644
index 000000000..fdfb3f5ec
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-napoleon-0.7.tar.gz 21232 BLAKE2B c64433a9e42d7f68ffca0f3d45e927a10ff8a67e47d0d05f19614c1625db29633774155a9ddb48fb1a32fe04710ecb597fc13b393738afb7266afc6e62526346 SHA512 000fc00b21148ed38b3f0beed5163e232f50642369641a940fd77b30c3c426d799144b3e1c7fbc4dd86b5b1f526656b56be7d77239d4cd3a14dd93178c0e13f8
diff --git a/dev-python/sphinxcontrib-napoleon/metadata.xml b/dev-python/sphinxcontrib-napoleon/metadata.xml
new file mode 100644
index 000000000..ca93985fb
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7.ebuild b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7.ebuild
new file mode 100644
index 000000000..cdb82f956
--- /dev/null
+++ b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allow a different format in dosctrings for better clarity"
+HOMEPAGE="https://sphinxcontrib-napoleon.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/pockets[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}