aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-08-12 20:52:31 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-08-12 20:52:31 +0200
commit43ec5bc0f4e73657b62ba1039bea2962d4d92465 (patch)
tree1acb5b1c7f04b00f45cd4b6a07881d250f351c6e /dev-python/testpath/testpath-9999.ebuild
parentdev-python/jupyter_console: Initial ebuild (diff)
downloadsci-43ec5bc0f4e73657b62ba1039bea2962d4d92465.tar.gz
sci-43ec5bc0f4e73657b62ba1039bea2962d4d92465.tar.bz2
sci-43ec5bc0f4e73657b62ba1039bea2962d4d92465.zip
dev-python/testpath: Initial ebuild
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/testpath/testpath-9999.ebuild')
-rw-r--r--dev-python/testpath/testpath-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/testpath/testpath-9999.ebuild b/dev-python/testpath/testpath-9999.ebuild
new file mode 100644
index 000000000..63bab30b7
--- /dev/null
+++ b/dev-python/testpath/testpath-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
+else
+ SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-setup.py.patch)