aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-01-16 11:57:30 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-18 17:37:47 +0100
commit00f4b8580ff4f674371314ce2ca7f2366dbfc0c5 (patch)
tree7ff1b9739d6bf61498d5a4a70e95ad16b1feec02 /dev-python
parentdev-python/affine: new 2.3.0 (diff)
downloadsci-00f4b8580ff4f674371314ce2ca7f2366dbfc0c5.tar.gz
sci-00f4b8580ff4f674371314ce2ca7f2366dbfc0c5.tar.bz2
sci-00f4b8580ff4f674371314ce2ca7f2366dbfc0c5.zip
dev-python/snuggs: new 1.4.7
dep for dev-python/rasterio status: test pass, works for me Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snuggs/Manifest1
-rw-r--r--dev-python/snuggs/metadata.xml17
-rw-r--r--dev-python/snuggs/snuggs-1.4.7.ebuild26
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/snuggs/Manifest b/dev-python/snuggs/Manifest
new file mode 100644
index 000000000..d9ccc74fd
--- /dev/null
+++ b/dev-python/snuggs/Manifest
@@ -0,0 +1 @@
+DIST snuggs-1.4.7.tar.gz 7762 BLAKE2B fae10c4e6f759219cbecdbea4b8f49001980824fe1d43fba9d5b62837a88183d1ecb6f55e191b637048e03856b1c6466cb17a9c38dfa332537d8968c8510fc25 SHA512 c1f40e521d1b0cf15075b22b04000c74ecbd0522cdd820b8c159aac812924d877349b3f3bca93b09eed5b025a34c26665a41c7a52a8145419558b115cf8ef361
diff --git a/dev-python/snuggs/metadata.xml b/dev-python/snuggs/metadata.xml
new file mode 100644
index 000000000..19390156e
--- /dev/null
+++ b/dev-python/snuggs/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Snuggs library parses S-expressions using numpy. Available function
+ include arithmetic and logical operators. Also members of the numpy
+ module such as "asarray()", "mean()" and "where" are available.
+</longdescription>
+ <upstream>
+ <remote-id type="github">mapbox/snuggs</remote-id>
+ <remote-id type="pypi">snuggs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/snuggs/snuggs-1.4.7.ebuild b/dev-python/snuggs/snuggs-1.4.7.ebuild
new file mode 100644
index 000000000..ebae883ff
--- /dev/null
+++ b/dev-python/snuggs/snuggs-1.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1
+
+DESCRIPTION="S-expressions for numpy"
+HOMEPAGE="https://github.com/mapbox/snuggs"
+SRC_URI="https://github.com/mapbox/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest