aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-10-12 09:09:11 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-10-12 09:09:11 +0200
commit1ed88b3f6385598b9376b24e454264e9542758a0 (patch)
tree4e970f9f0b3df51c5ffc014b782ede6cf74aa621 /dev-python
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-1ed88b3f6385598b9376b24e454264e9542758a0.tar.gz
sci-1ed88b3f6385598b9376b24e454264e9542758a0.tar.bz2
sci-1ed88b3f6385598b9376b24e454264e9542758a0.zip
dev-python/matplotlib2tikz: Version bump to 0.5.14
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 2cd6fc63b..c858020fd 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
+DIST matplotlib2tikz-0.5.14.tar.gz 24290 SHA256 4759a4af7fcce23e0ea1aaa875d1c2b31f26f4412513603c1f6524a9fe48964f SHA512 8924e20663a740f19c8264da52284965cd23c41f01fb0118e06618edf8d3c1976942191d4e0a43a4c5be3b4c015c9392fd524ffb13af19c9d3a69b3b7f775327 WHIRLPOOL 42ada6d0e947d20fe8c1ca047ae13065f877d067536f7a6377f784bef73adbf83ec812b5f24b29573f1120dca6616e375fb18b2c0b3b833c3913c767f297108f
DIST matplotlib2tikz-0.5.7.tar.gz 22830 SHA256 67586786b83c92266e1796f7dbbb458301c38ea8320fcb6c05f906c82713403d SHA512 18f7c945e83a3f04edc38a76becdfa4c1c6293e8ec869b18723981f7cab201a6998ce63d2b36c32415f9c7f740c8d43c534881def1b3b469aa4976b7e1ef6f27 WHIRLPOOL 7a64a29e8052f4caa3c132cf2bc4e72cf7f8813f5ceae0ed1dc5fbdd6bfa93dab7b050826213e40a3a07279991c27c83021f2aa0ed079e6e2eab5b6a4976d51d
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild
new file mode 100644
index 000000000..8a22daf5c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"