aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-07-12 08:31:44 -0400
committerHorea Christian <chr@chymera.eu>2022-07-12 08:31:44 -0400
commit244c134feee107bef9df51f04d74485f9e16f91a (patch)
treec9a6f54e7ebd466059feda32d0c4298f39dca0d3 /dev-python
parentsci-libs/nipype: EAPI and PYTHON_COMPAT bump, test fix (diff)
downloadsci-244c134feee107bef9df51f04d74485f9e16f91a.tar.gz
sci-244c134feee107bef9df51f04d74485f9e16f91a.tar.bz2
sci-244c134feee107bef9df51f04d74485f9e16f91a.zip
dev-python/wraps: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wraps/Manifest1
-rw-r--r--dev-python/wraps/files/wraps-0.1.0-poetry_groups.patch61
-rw-r--r--dev-python/wraps/metadata.xml15
-rw-r--r--dev-python/wraps/wraps-0.1.0.ebuild30
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/wraps/Manifest b/dev-python/wraps/Manifest
new file mode 100644
index 000000000..bf3a9ad34
--- /dev/null
+++ b/dev-python/wraps/Manifest
@@ -0,0 +1 @@
+DIST wraps-0.1.0.tar.gz 15438 BLAKE2B 16a9b0f09c3443d884f0ac01ddb66ad7fa50085a11ad5e9eb6d25a50bbe936dd19e3735ddc0354c285d2ca86615b2c7290c46e4e1cfb4b8f54adec073569c0f2 SHA512 bd4acb117db425b99be0d9f0075d019def839490c9ddf47f1ec2a2ddf3f3ff785c1ad8d0b4a79a70f4070c1a7ac71dff81b02e76d21a4b85accb3e612123ab9a
diff --git a/dev-python/wraps/files/wraps-0.1.0-poetry_groups.patch b/dev-python/wraps/files/wraps-0.1.0-poetry_groups.patch
new file mode 100644
index 000000000..8a6de2917
--- /dev/null
+++ b/dev-python/wraps/files/wraps-0.1.0-poetry_groups.patch
@@ -0,0 +1,61 @@
+--- a/pyproject.toml 2022-06-28 11:08:09.624127900 -0400
++++ b/pyproject.toml 2022-07-11 16:33:14.810411482 -0400
+@@ -37,29 +37,6 @@
+
+ typing-extensions = ">= 4.2.0"
+
+-[tool.poetry.group.format]
+-optional = true
+-
+-[tool.poetry.group.format.dependencies]
+-black = "22.6.0"
+-
+-[tool.poetry.group.format.dependencies.isort]
+-version = "5.10.1"
+-python = "^3.7"
+-
+-[tool.poetry.group.check]
+-optional = true
+-
+-[tool.poetry.group.check.dependencies]
+-mypy = "0.961"
+-
+-[tool.poetry.group.test]
+-optional = true
+-
+-[tool.poetry.group.test.dependencies]
+-pytest = "7.1.2"
+-pytest-cov = "3.0.0"
+-
+ [tool.black]
+ line_length = 100
+
+@@ -67,29 +44,6 @@
+ line_length = 100
+ profile = "black"
+
+-[tool.pytest.ini_options]
+-addopts = "--cov wraps"
+-testpaths = ["tests"]
+-
+-[tool.coverage.run]
+-source = ["wraps"]
+-
+-[tool.coverage.report]
+-ignore_errors = true
+-exclude_lines = [
+- "pragma: never",
+- "pragma: no cover",
+- "if TYPE_CHECKING",
+- "@overload",
+- "@abstractmethod",
+- "raise NotImplementedError",
+- "raise AssertionError",
+- "def __repr__",
+-]
+-
+-[tool.coverage.html]
+-directory = "coverage"
+-
+ [tool.mypy]
+ show_column_numbers = true
diff --git a/dev-python/wraps/metadata.xml b/dev-python/wraps/metadata.xml
new file mode 100644
index 000000000..dd3bf5227
--- /dev/null
+++ b/dev-python/wraps/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nekitdev/wraps</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wraps/wraps-0.1.0.ebuild b/dev-python/wraps/wraps-0.1.0.ebuild
new file mode 100644
index 000000000..8ec771d57
--- /dev/null
+++ b/dev-python/wraps/wraps-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION=" Meaningful and safe wrapping types. "
+HOMEPAGE="https://github.com/nekitdev/wraps"
+SRC_URI="https://github.com/nekitdev/wraps/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+# package does not have test suite (yet)
+
+RDEPEND="
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+ "
+
+PATCHES=(
+ "${FILESDIR}/${P}-poetry_groups.patch"
+)
+
+distutils_enable_tests pytest