aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-07-27 14:07:57 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-07-27 14:07:57 +0200
commit246dc00fba726ba1a4d720a4aa4ccd8cbf9f65e9 (patch)
tree0ba72f8b28ce9e136a9ec6136d9aa6436ed4dbf8 /dev-python
parentdev-python/jupyter_core: Bump to EAPI=6; Adopt to ebuild in tree (diff)
downloadsci-246dc00fba726ba1a4d720a4aa4ccd8cbf9f65e9.tar.gz
sci-246dc00fba726ba1a4d720a4aa4ccd8cbf9f65e9.tar.bz2
sci-246dc00fba726ba1a4d720a4aa4ccd8cbf9f65e9.zip
dev-python/jupyter_console: Bump to EAPI=6; Adopt to ebuild in tree
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_console/jupyter_console-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-9999.ebuild b/dev-python/jupyter_console/jupyter_console-9999.ebuild
index ed0be7ccb..d68c9ffd0 100644
--- a/dev-python/jupyter_console/jupyter_console-9999.ebuild
+++ b/dev-python/jupyter_console/jupyter_console-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
@@ -20,6 +20,8 @@ RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
@@ -27,7 +29,6 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/pexpect[${PYTHON_USEDEP}]
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
)
"