aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-01-16 12:00:08 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-18 17:37:49 +0100
commit24a43c1dc1667952ac9e740da73c4b8c676f20a0 (patch)
tree51d283eb2868b45dec98acae63c535d4d32953c7 /dev-python
parentdev-python/rasterstats: new 0.16.0 (diff)
downloadsci-24a43c1dc1667952ac9e740da73c4b8c676f20a0.tar.gz
sci-24a43c1dc1667952ac9e740da73c4b8c676f20a0.tar.bz2
sci-24a43c1dc1667952ac9e740da73c4b8c676f20a0.zip
dev-python/fiona: new 1.8.20
dep for dev-python/{geopandas,rasterstats} status: test pass, works for me Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fiona/Manifest1
-rw-r--r--dev-python/fiona/fiona-1.8.20.ebuild74
-rw-r--r--dev-python/fiona/metadata.xml18
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/fiona/Manifest b/dev-python/fiona/Manifest
new file mode 100644
index 000000000..6f48f8721
--- /dev/null
+++ b/dev-python/fiona/Manifest
@@ -0,0 +1 @@
+DIST fiona-1.8.20.tar.gz 269491 BLAKE2B 0778a0824e3ecd70fc7a153a4be4631c04e70dc6218c3c78e7ddffae01db22a081f8f8b7f44cce37f864e32277b88596263d6ac640293c93e6a14ec7a932aa04 SHA512 4864f3c48903b34c6b4d2cf5dcdc5ebb6e155e32e7e138bdf17756a823f36a0985162c211127b283235569235c830e11abd330c229b2bb8de6cee053fe3204d7
diff --git a/dev-python/fiona/fiona-1.8.20.ebuild b/dev-python/fiona/fiona-1.8.20.ebuild
new file mode 100644
index 000000000..1127afa70
--- /dev/null
+++ b/dev-python/fiona/fiona-1.8.20.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1
+
+DESCRIPTION="API for reading/writing vector geospatial data"
+HOMEPAGE="https://github.com/Toblerity/fiona"
+SRC_URI="https://github.com/Toblerity/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-libs/gdal[geos,sqlite,python,${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/cligj[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ sci-libs/gdal[geos,sqlite,python,${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/Fiona-${PV}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # disable tests due to networking blocked
+ tests/test_vfs.py::test_open_http
+ tests/test_vfs.py::test_open_zip_https
+ tests/test_collection.py::test_collection_http
+ tests/test_collection.py::test_collection_zip_http
+
+ # disable tests failing due to deprecated GDAL features
+ tests/test_data_paths.py::test_gdal_data_wheel
+ tests/test_data_paths.py::test_proj_data_wheel
+ tests/test_data_paths.py::test_env_gdal_data_wheel
+ tests/test_data_paths.py::test_env_proj_data_wheel
+ tests/test_datetime.py::test_datefield[GPSTrackMaker-datetime]
+ tests/test_datetime.py::test_datefield_null[GPSTrackMaker-datetime]
+ tests/test_drvsupport.py::test_write_or_driver_error[GPSTrackMaker]
+ tests/test_drvsupport.py::test_no_append_driver_cannot_append[GPSTrackMaker]
+ tests/test_drvsupport.py::test_no_append_driver_cannot_append[PCIDSK]
+ tests/test_drvsupport.py::test_write_or_driver_error[DGN]
+
+ # geos
+ #tests/test_collection.py::test_mask_polygon_triangle
+ #tests/test_collection.py::test_mask_polygon_triangle
+ #tests/test_collection.py::test_mask_polygon_triangle
+
+ # sqlite
+ #tests/test_schema.py::test_geometry_only_schema_write[GPKG]
+ #tests/test_schema.py::test_geometry_only_schema_update[GPKG]
+ #tests/test_schema.py::test_property_only_schema_write[GPKG]
+ #tests/test_schema.py::test_property_only_schema_update[GPKG]
+ )
+
+ mv fiona{,.bak} || die # Avoid non-working local import
+ epytest ${deselect[@]/#/--deselect }
+ mv fiona{.bak,} || die
+}
diff --git a/dev-python/fiona/metadata.xml b/dev-python/fiona/metadata.xml
new file mode 100644
index 000000000..e1e191ee0
--- /dev/null
+++ b/dev-python/fiona/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fiona reads and writes geographic data files and thereby helps Python
+ programmers integrate geographic information systems with other
+ computer systems. Fiona contains extension modules that link the
+ Geospatial Data Abstraction Library (GDAL).
+</longdescription>
+ <upstream>
+ <remote-id type="github">Toblerity/fiona</remote-id>
+ <remote-id type="pypi">Fiona</remote-id>
+ </upstream>
+</pkgmetadata>