aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-21 21:40:54 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-21 21:41:04 +0000
commit278ea78681e753d7f372ae2ded55da98fc941f40 (patch)
treefde5c594c324ce0d9934835b6838348e711dedaf /dev-python
parentlicense: Add XVIEW liecense (diff)
downloadsci-278ea78681e753d7f372ae2ded55da98fc941f40.tar.gz
sci-278ea78681e753d7f372ae2ded55da98fc941f40.tar.bz2
sci-278ea78681e753d7f372ae2ded55da98fc941f40.zip
dev-python/bokeh: version bump to 2.2.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bokeh/Manifest1
-rw-r--r--dev-python/bokeh/bokeh-2.2.3.ebuild85
-rw-r--r--dev-python/bokeh/packs21
3 files changed, 86 insertions, 21 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
index c3f2c69e4..93cc6a37e 100644
--- a/dev-python/bokeh/Manifest
+++ b/dev-python/bokeh/Manifest
@@ -1,2 +1,3 @@
DIST bokeh-2.2.1.tar.gz 8845855 BLAKE2B 54846c4033a57677a197ee736266993401e00da791b0b2202e2d1683cb044d26f0ab958340f3ed2603bc78100e30b09aa7e569fff26eb235ebcb53beb7720b3a SHA512 8f58196468750f8fa24b4a8165ecb1407e61cfe207f1e0c82f0efc83d7b41f1db73ae56363e52bccc3b1f1cb9cc93f1a3ab40af0bb4b981e8b241c4c19c7b900
DIST bokeh-2.2.2.tar.gz 8847568 BLAKE2B b279e72106ec7771fbdad6709d529e5b5e23152eae6feeae2b5cddceeba1d9db5def6c1f99cb884739536b2ecbe33060531a229f8838bcf4fa69aadf42053619 SHA512 5a53a11e3252dd904c5a436733f520251b7990bf2f112315cd5c76f0d26a6733888a36f73954c3339647981971400fc815710a3a9a753db4c9cdf10c5e2a1643
+DIST bokeh-2.2.3.tar.gz 8848373 BLAKE2B 4bae1e729980bced589c256213df22cabc08b8105113698b0e5eefd37760506a625212931dcafb8c00f1a2fce1b77a48b4802ede4a3f09c73f09b8dbe39a1a81 SHA512 7d7cf6b4207644894c8a358e235f2901f65b453f3324c1b766ddca67b287e13e82df67c193ba87123d5b3b855f7ba29c01e2113fb787dd60c39bef6ba7c95aba
diff --git a/dev-python/bokeh/bokeh-2.2.3.ebuild b/dev-python/bokeh/bokeh-2.2.3.ebuild
new file mode 100644
index 000000000..206e6962e
--- /dev/null
+++ b/dev-python/bokeh/bokeh-2.2.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# upstream hasn't tested python 3.8 fully
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Statistical and interactive HTML plots for Python"
+HOMEPAGE="https://bokeh.org/
+ https://github.com/bokeh/bokeh
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# upstream authoritative dependencies
+# https://github.com/bokeh/bokeh/blob/master/conda.recipe/meta.yaml
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.1-conftest_py.patch
+)
+
+python_test() {
+ # disable tests having network calls
+ local SKIP_TESTS=" \
+ not (test___init__ and TestWarnings and test_filters) and \
+ not (test_json__subcommands and test_no_script) and \
+ not (test_standalone and Test_autoload_static) and \
+ not test_nodejs_compile_javascript and \
+ not test_nodejs_compile_less and \
+ not test_inline_extension and \
+ not (test_model and test_select) and \
+ not test_tornado__server and \
+ not test_client_server and \
+ not test_webdriver and \
+ not test_export and \
+ not test_server and \
+ not test_bundle and \
+ not test_ext \
+ "
+ pytest -m "not sampledata" tests/unit -k \
+ "${SKIP_TESTS}" -vv || die "unittests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "integration with amazon S3" dev-python/boto
+ optfeature "pypi integration to publish packages" dev-python/twine
+ optfeature "js library usage" net-libs/nodejs
+}
diff --git a/dev-python/bokeh/packs b/dev-python/bokeh/packs
deleted file mode 100644
index c6ffec3a0..000000000
--- a/dev-python/bokeh/packs
+++ /dev/null
@@ -1,21 +0,0 @@
- dev-python/beautifulsoup
- dev-python/boto
- dev-python/colorama
- dev-python/flaky
- dev-python/ipython
- dev-python/pandas
- dev-python/pytest
- dev-python/pytest-asyncio
- dev-python/pytest-html
- dev-python/pytest-xdist
- dev-python/mypy
- dev-python/mock
- dev-python/networkx
- dev-python/nbconvert
- dev-python/nbformat
- dev-python/pytest-rerunfailures
- dev-python/pytest-xdist
- dev-python/selenium
- dev-ruby/selenium-webdriver
- net-libs/nodejs
- dev-python/scipy