aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-23 04:13:42 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-12-23 04:13:42 +0000
commit29b1b634500b41d138fd3c6f14c5f7f8e01622ac (patch)
tree87b853f66fa7c8ae5c5b9cd14bb3605d0198ac61 /dev-python
parentdev-python/pynndescent: version bump to 0.5.1 (diff)
downloadsci-29b1b634500b41d138fd3c6f14c5f7f8e01622ac.tar.gz
sci-29b1b634500b41d138fd3c6f14c5f7f8e01622ac.tar.bz2
sci-29b1b634500b41d138fd3c6f14c5f7f8e01622ac.zip
dev-python/python-igraph: version bump to 0.8.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-igraph/Manifest1
-rw-r--r--dev-python/python-igraph/python-igraph-0.8.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-igraph/Manifest b/dev-python/python-igraph/Manifest
index c06f6e8dc..dfc8129df 100644
--- a/dev-python/python-igraph/Manifest
+++ b/dev-python/python-igraph/Manifest
@@ -1 +1,2 @@
DIST python-igraph-0.8.2.tar.gz 3970354 BLAKE2B 2107a147ad98fa0b1a6c4f7332167a4256225615b9ef457e7c4b39c63cbe97456b4952e7c208ab0712365e1103eb541f4f8d0f0554470132b05b57bcc8f1dc67 SHA512 669d44081de2f0e1d0ef5b06e1cced193a9a0686e3e5e58b8334fd6eef14df3226cd0f7902f88289e575c822516e85b442c89ca9ec73a0d9d48ac8522347a30a
+DIST python-igraph-0.8.3.tar.gz 4059460 BLAKE2B 795dee8a72450c8d6ccf88188f663f54b3e7b551de2ceff8f7104a97f64741f8e5a02e2ef9b3d4e09806c26ba85e75c39c9ab99dc5019437db780f23dc1bb629 SHA512 5015a339ac4f0aa9a08942396f97c667602c760491cccb85ff8ef807f1be47d4e3c66a4145c5064c19ec8657ddac02a9ae88f460ab2e1c3394348de100879c90
diff --git a/dev-python/python-igraph/python-igraph-0.8.3.ebuild b/dev-python/python-igraph/python-igraph-0.8.3.ebuild
new file mode 100644
index 000000000..7e7eca0a1
--- /dev/null
+++ b/dev-python/python-igraph/python-igraph-0.8.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for igraph"
+HOMEPAGE="https://igraph.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/igraph
+ dev-python/texttable[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile --use-pkg-config
+}