aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:27:19 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:27:19 +0100
commit338608f333c20a5980dc0caef9d062b6f09dbdb9 (patch)
treef1d7d885253834d157310ecc61e69b2849b90939 /dev-python
parentdev-python/gmsh_interop: bump to 2021.1.1 (diff)
downloadsci-338608f333c20a5980dc0caef9d062b6f09dbdb9.tar.gz
sci-338608f333c20a5980dc0caef9d062b6f09dbdb9.tar.bz2
sci-338608f333c20a5980dc0caef9d062b6f09dbdb9.zip
dev-python/meshpy: bump to 2020.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/meshpy/Manifest3
-rw-r--r--dev-python/meshpy/meshpy-2018.2.1_p1.ebuild51
-rw-r--r--dev-python/meshpy/meshpy-2020.1.ebuild (renamed from dev-python/meshpy/meshpy-2018.2.1.ebuild)24
3 files changed, 10 insertions, 68 deletions
diff --git a/dev-python/meshpy/Manifest b/dev-python/meshpy/Manifest
index 82dd9c18b..b39e4ba75 100644
--- a/dev-python/meshpy/Manifest
+++ b/dev-python/meshpy/Manifest
@@ -1,2 +1 @@
-DIST meshpy-2018.2.1.tar.gz 493048 BLAKE2B 78a84bdf8af6228f991a8f724131dfe4f32cff156cb3c148894d4b2c07bfa30d192fc2830f5161cdc555c45aeff4a1189862a6e627bb1bfb4170b5f819b4538a SHA512 779a6fe6694eb381a32cb7304091402a11c019dbde75391c36aa9e76c57ee8b76f2215856c2998e58a7cee2b77626661f8b6518f54e5e6f2112f79acb3151d9d
-DIST meshpy-2018.2.1_p1.tar.gz 494699 BLAKE2B 2f8ca25e193437d5e4fd01c5ebbd6c1a6cb38103754455bec91d120484b89451bc9d34157a369ffcfb248ab4d993e1e0b015f20b80a558f97934f9302152aedf SHA512 9f830a32d8c7c32f34eb0dbdf7341bf49d03451957ea8b319639f6afc15fdfe43a8852a1049878fd1827822016aefca05794a588d6d3fd26c9471d52783e8f81
+DIST meshpy-2020.1.tar.gz 482475 BLAKE2B fe59de6fae837db584c38ee0f8ad7d9e242624df360fa0c0eb2778f1d2ea6233e6f92f113014dfc73f570dbb47c65582775ec3c615cd887b5aefdb7030794b90 SHA512 d328a546f14db44a40e885554cf3bfff1e522a1ce38b312acaf6ac7ddc6fd909299fb78793229482ec51ccb2484baee13c2c09406be937a073555cc120f6f2df
diff --git a/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild b/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild
deleted file mode 100644
index 6985305a0..000000000
--- a/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_IN_SOURCE_BUILD=1
-PYTHON_COMPAT=( python3_{6..8} )
-
-inherit distutils-r1
-
-MY_PN="MeshPy"
-
-DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
-HOMEPAGE="https://mathema.tician.de/software/meshpy
- https://pypi.python.org/pypi/MeshPy
-"
-
-COMMIT=6f4f9418f5f02b414d561bd8de710c4f1349ea72
-SRC_URI="https://github.com/inducer/meshpy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="
- dev-libs/boost[python,${PYTHON_USEDEP}]
- dev-python/gmsh_interop[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- dev-python/pytools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- sci-libs/gmsh
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed 's:delay=10:delay=1:g' -i aksetup_helper.py || die
-
-# echo "BOOST_PYTHON_LIBNAME = ['boost_${EPYTHON}-mt']">> "${S}"/siteconf.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/meshpy/meshpy-2018.2.1.ebuild b/dev-python/meshpy/meshpy-2020.1.ebuild
index 5df9336ad..191589690 100644
--- a/dev-python/meshpy/meshpy-2018.2.1.ebuild
+++ b/dev-python/meshpy/meshpy-2020.1.ebuild
@@ -1,24 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_IN_SOURCE_BUILD=1
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
+MY_PN="MeshPy"
+
DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
HOMEPAGE="https://mathema.tician.de/software/meshpy
https://pypi.python.org/pypi/MeshPy
"
-
SRC_URI="https://github.com/inducer/meshpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
+
+# ModuleNotFoundError: No module named 'meshpy._internals'
+RESTRICT="test"
RDEPEND="
dev-libs/boost[python,${PYTHON_USEDEP}]
@@ -26,22 +29,13 @@ RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
dev-python/pytools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
sci-libs/gmsh
"
DEPEND="${RDEPEND}"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
python_prepare_all() {
sed 's:delay=10:delay=1:g' -i aksetup_helper.py || die
-
-# echo "BOOST_PYTHON_LIBNAME = ['boost_${EPYTHON}-mt']">> "${S}"/siteconf.py
-
distutils-r1_python_prepare_all
}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "tests failed with ${EPYTHON}"
-}