aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:26:10 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:26:10 +0100
commit34eb310028b9d6cf5811bc6390a5badc59ae908e (patch)
tree309fc3159ea369adec2254aa03c12cec621077c3 /dev-python
parentnet-misc/cernbox-client: Drop old. (diff)
downloadsci-34eb310028b9d6cf5811bc6390a5badc59ae908e.tar.gz
sci-34eb310028b9d6cf5811bc6390a5badc59ae908e.tar.bz2
sci-34eb310028b9d6cf5811bc6390a5badc59ae908e.zip
dev-python/asdf: bump to version 2.8.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/asdf/Manifest2
-rw-r--r--dev-python/asdf/asdf-2.8.3.ebuild (renamed from dev-python/asdf/asdf-2.7.1.ebuild)10
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/asdf/Manifest b/dev-python/asdf/Manifest
index ed535128d..3b2cf6ef8 100644
--- a/dev-python/asdf/Manifest
+++ b/dev-python/asdf/Manifest
@@ -1 +1 @@
-DIST asdf-2.7.1.tar.gz 494491 BLAKE2B 7ff36829626972e85362cb364bdf5ced4745a592c7229b70584ef36722935959a21c6cc11a37ea58c625c1aefdee96d72d5edfef67e5a7975c653f70ed9689c1 SHA512 dc807013d7dbf67c8cb269398d0b7ff56b1c5212d2cfbb768b7844979951c56b9263327cba3a3db32b65ac9de2ede94731823b4d7f120a4306efc203cfc75266
+DIST asdf-2.8.3.tar.gz 513853 BLAKE2B 73afb6f5799a13689bd2be73b8d9b45d5bb4a1f093654e3d8a0796a6342f03deabe64c6de4d33213ba762e3b2508541a25b24cccc490f0685714180af6790c43 SHA512 c3b72ed7fefd33958413c962d81213d2d141072473e08c767059a3ff46ba03f0135c9435a7893eb0eb43b199e2c701d62f263a487872a120465979dfec8988df
diff --git a/dev-python/asdf/asdf-2.7.1.ebuild b/dev-python/asdf/asdf-2.8.3.ebuild
index ddace4966..96663e49a 100644
--- a/dev-python/asdf/asdf-2.7.1.ebuild
+++ b/dev-python/asdf/asdf-2.8.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -27,8 +27,8 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
"
RDEPEND="
+ >=dev-python/jmespath-0.6.2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-3.0.2[${PYTHON_USEDEP}]
- <dev-python/jsonschema-4[${PYTHON_USEDEP}]
>=dev-python/numpy-1.10[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
>=dev-python/semantic_version-2.8[${PYTHON_USEDEP}]
@@ -40,5 +40,5 @@ distutils_enable_sphinx docs dev-python/astropy dev-python/sphinx-astropy dev-py
python_test() {
# discovers things in docs dir if we do not
# explicitly set it to run on the tests dir
- pytest -vv asdf/tests || die " Tests failed with ${EPYTHON}"
+ epytest asdf/tests
}