aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-05-09 20:17:33 -0400
committerHorea Christian <chr@chymera.eu>2024-05-09 20:17:33 -0400
commit39aa26e66beae16887de80286c1e97baf6432981 (patch)
treeea74aab5ee1eb4d72248afd51eae479224050dea /dev-python
parentprofiles: unmasked samri, heudiconv (diff)
downloadsci-39aa26e66beae16887de80286c1e97baf6432981.tar.gz
sci-39aa26e66beae16887de80286c1e97baf6432981.tar.bz2
sci-39aa26e66beae16887de80286c1e97baf6432981.zip
dev-python/aiohttp-retry: new package, add 2.8.3
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp-retry/Manifest1
-rw-r--r--dev-python/aiohttp-retry/aiohttp-retry-2.8.3.ebuild31
-rw-r--r--dev-python/aiohttp-retry/metadata.xml16
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/aiohttp-retry/Manifest b/dev-python/aiohttp-retry/Manifest
new file mode 100644
index 000000000..f050b37c0
--- /dev/null
+++ b/dev-python/aiohttp-retry/Manifest
@@ -0,0 +1 @@
+DIST aiohttp-retry-2.8.3.gh.tar.gz 11952 BLAKE2B f2ea6f7b2f13001bd8d49b4529eacb3766cab080ff3a9457e40287bc797afebae10393a628cf78756074ca60a62df78c59c6120f1368316084155f1d7fd7cdfb SHA512 71869c3997e9b5089c298fa6f992b0ed08ca3da0f93c4f37566d8c6b9809bb1873a629cc47f1ffaeccac112d96036851794ee564b11c0f4f1eec00f49413358d
diff --git a/dev-python/aiohttp-retry/aiohttp-retry-2.8.3.ebuild b/dev-python/aiohttp-retry/aiohttp-retry-2.8.3.ebuild
new file mode 100644
index 000000000..25df27ba6
--- /dev/null
+++ b/dev-python/aiohttp-retry/aiohttp-retry-2.8.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple retry client for aiohttp"
+HOMEPAGE="https://github.com/inyutin/aiohttp_retry"
+# Test suite missing from PyPI tarball, reported upstream:
+# https://github.com/inyutin/aiohttp_retry/issues/94
+SRC_URI="https://github.com/inyutin/aiohttp_retry/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/aiohttp-retry/metadata.xml b/dev-python/aiohttp-retry/metadata.xml
new file mode 100644
index 000000000..900a7e9f8
--- /dev/null
+++ b/dev-python/aiohttp-retry/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">inyutin/aiohttp_retry</remote-id>
+ <remote-id type="pypi">aiohttp-retry</remote-id>
+ </upstream>
+</pkgmetadata>