aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-04-01 15:57:57 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-04-01 15:57:57 +0200
commit3b2ee652252efb4287136d0713eecb199f5ff44f (patch)
tree189c1b4b298b780fe00601cb4fc1170facdca2ae /dev-python
parentsci-biology/bamtools: version bump; still suffers gentoo bug #550144 (diff)
downloadsci-3b2ee652252efb4287136d0713eecb199f5ff44f.tar.gz
sci-3b2ee652252efb4287136d0713eecb199f5ff44f.tar.bz2
sci-3b2ee652252efb4287136d0713eecb199f5ff44f.zip
dev-python/matplotlib2tikz: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.5.6.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 42208953d..a0e32a355 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.5.4.tar.gz 22767 SHA256 c4d1e475431a956c0374e12151d14b202861ae3c2beff14c0c56d139151332f9 SHA512 bad02eaa89d3fa3252da9c785df4c991a6a35c3056f0446bba936e8787012bd2269f6ef1b65d4583f1d832b185dd3103491ed6ef28a5ecd9ef99bfa001a60cda WHIRLPOOL eb18e6b09632606930858c1dac7b7658ed41c4efb538515e932ab74e320e03cf5efc34c0ff370a0cd58576e3bd3acfda3908dc64194b392e7160f6c188dc227f
+DIST matplotlib2tikz-0.5.6.tar.gz 22808 SHA256 45e704e112d93bdbea14ed14f350d52ad954fb0cef393b83fa03d1ffbc428d96 SHA512 989543a19cab3ff1957d7eadcc5c192fa6903445aead2dd090a81ceac6832267b859896c27504311bf05de8d92b0bb304d2bcdab8612b7b007b2b9b59febdfe2 WHIRLPOOL ddb682a572897d88e443ff6657a17403a4a25c6fc63fed9d67afa9f483e2e9f4717a29bb843bf042626d763c48e257fea895e0f39dbad5a4801011edb052e5bc
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.6.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.6.ebuild
new file mode 100644
index 000000000..ec78e4f0b
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.5.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into native Pgfplots (TikZ) figures"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-texlive/texlive-pictures"
+DEPEND="${RDEPEND}"
+ #test? ( dev-python/pytest[${PYTHON_USEDEP}] )"