aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-01 22:55:58 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-17 18:21:58 +0100
commit4cb594edf14664ac6c2423bbed71f5ccc5f69223 (patch)
tree2e07148f9f649a9a2405dd871e2683db10230f59 /dev-python
parentdev-python/vector: new package, add 1.1.1 (diff)
downloadsci-4cb594edf14664ac6c2423bbed71f5ccc5f69223.tar.gz
sci-4cb594edf14664ac6c2423bbed71f5ccc5f69223.tar.bz2
sci-4cb594edf14664ac6c2423bbed71f5ccc5f69223.zip
dev-python/boost-histogram: new package, add 1.4.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/sci/pull/1235 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boost-histogram/Manifest1
-rw-r--r--dev-python/boost-histogram/boost-histogram-1.4.0.ebuild39
-rw-r--r--dev-python/boost-histogram/metadata.xml19
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boost-histogram/Manifest b/dev-python/boost-histogram/Manifest
new file mode 100644
index 000000000..1fb711744
--- /dev/null
+++ b/dev-python/boost-histogram/Manifest
@@ -0,0 +1 @@
+DIST boost_histogram-1.4.0.tar.gz 1329002 BLAKE2B 1636ed04c5df2f6c156468ffc0fed7b82469bb903c316b1b9fd209b7072ebb5b0de9969f4f8b50da69db7ee40009df534959db7734f1161da2c6216bddce858b SHA512 e7f61cc2d013a0664646d9edf1f713eb5f06f000ad2105e90229ef9b01b25a08c8e717a2ac241ed990fa2c082a1bb84af18e17b238640de5679d0ab76ff08af6
diff --git a/dev-python/boost-histogram/boost-histogram-1.4.0.ebuild b/dev-python/boost-histogram/boost-histogram-1.4.0.ebuild
new file mode 100644
index 000000000..0336c4e87
--- /dev/null
+++ b/dev-python/boost-histogram/boost-histogram-1.4.0.ebuild
@@ -0,0 +1,39 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the C++14 Boost::Histogram library"
+HOMEPAGE="https://github.com/scikit-hep/boost-histogram"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ default
+ sed -i 's/"pytest-benchmark"//g' pyproject.toml || die
+}
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmark_1d.py
+ tests/test_benchmark_2d.py
+ tests/test_benchmark_category_axis.py
+ tests/test_pickle.py
+ tests/test_threaded_fill.py
+)
diff --git a/dev-python/boost-histogram/metadata.xml b/dev-python/boost-histogram/metadata.xml
new file mode 100644
index 000000000..345502cba
--- /dev/null
+++ b/dev-python/boost-histogram/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python bindings for Boost::Histogram (source), a C++14 library. This is one of the fastest libraries for histogramming, while still providing the power of a full histogram object. See what's new.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">boost-histogram</remote-id>
+ <remote-id type="github">scikit-hep/boost-histogram</remote-id>
+ </upstream>
+</pkgmetadata>