aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-27 15:03:00 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-27 17:07:10 +0100
commit5edb5364f5454e45df68b8fca3b621352e7905e8 (patch)
tree4fb2cb7f2122ca7b65a5f78f948db4d622b83f87 /dev-python
parentsci-physics/apfelxx: new package, add 4.8.0 (diff)
downloadsci-5edb5364f5454e45df68b8fca3b621352e7905e8.tar.gz
sci-5edb5364f5454e45df68b8fca3b621352e7905e8.tar.bz2
sci-5edb5364f5454e45df68b8fca3b621352e7905e8.zip
dev-python/uhi: new package, add 0.4.0
Closes: https://github.com/gentoo/sci/pull/1245 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uhi/Manifest1
-rw-r--r--dev-python/uhi/metadata.xml19
-rw-r--r--dev-python/uhi/uhi-0.4.0.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/uhi/Manifest b/dev-python/uhi/Manifest
new file mode 100644
index 000000000..199ee2a62
--- /dev/null
+++ b/dev-python/uhi/Manifest
@@ -0,0 +1 @@
+DIST uhi-0.4.0.tar.gz 52953 BLAKE2B b0c16c58c676f405d7b46398507968e92e4c3939a53224b49cbd935c3473800341903a9e9c5e3c598d68f171a9ec098feedaa774b2bbfe780581a663e99b2592 SHA512 4f7f0bdce3fef14c8789e0860956d6d4d2ab91e48eb95b6bceb67aef47b23a260f0f33a565c052fe48933f108adfe32f4c28c8cf874cc908929d407687bbc385
diff --git a/dev-python/uhi/metadata.xml b/dev-python/uhi/metadata.xml
new file mode 100644
index 000000000..c1ee047a1
--- /dev/null
+++ b/dev-python/uhi/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a package meant primarily for documenting histogram indexing and the PlottableHistogram Protocol and any future cross-library standards. It also contains the code for the PlottableHistogram Protocol, to be used in type checking libraries wanting to conform to the protocol. Eventually, it might gain a set of tools for testing conformance to UHI indexing, as well. It is not usually a runtime dependency, but only a type checking, testing, and/or docs dependency in support of other libraries (such as boost-histogram 0.13+, hist 2.1+, mplhep 0.2.15+, uproot 4+, and histoprint 2+). There are a few useful runtime usable components (listed below). It requires Python 3.6+. See what's new.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">uhi</remote-id>
+ <remote-id type="github">scikit-hep/uhi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uhi/uhi-0.4.0.ebuild b/dev-python/uhi/uhi-0.4.0.ebuild
new file mode 100644
index 000000000..89db57b1c
--- /dev/null
+++ b/dev-python/uhi/uhi-0.4.0.ebuild
@@ -0,0 +1,27 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Universal Histogram Interface"
+HOMEPAGE="https://github.com/scikit-hep/uhi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/boost-histogram[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest