aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-07 01:36:18 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-07 01:36:18 +0000
commit60a4b08ed1a8069e82d8346ea9275fbf44b35282 (patch)
tree30817bcd5c4ea7787f8e0626c3a29052a28397e0 /dev-python
parentsci-biology/libBigWig: drop old version (diff)
downloadsci-60a4b08ed1a8069e82d8346ea9275fbf44b35282.tar.gz
sci-60a4b08ed1a8069e82d8346ea9275fbf44b35282.tar.bz2
sci-60a4b08ed1a8069e82d8346ea9275fbf44b35282.zip
dev-python/pyBigWig: version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyBigWig/Manifest1
-rw-r--r--dev-python/pyBigWig/pyBigWig-0.3.17.ebuild24
-rw-r--r--dev-python/pyBigWig/pyBigWig-9999.ebuild22
3 files changed, 38 insertions, 9 deletions
diff --git a/dev-python/pyBigWig/Manifest b/dev-python/pyBigWig/Manifest
index 88325560d..48d0b4b90 100644
--- a/dev-python/pyBigWig/Manifest
+++ b/dev-python/pyBigWig/Manifest
@@ -1 +1,2 @@
+DIST pyBigWig-0.3.17.tar.gz 65490 BLAKE2B 5ae3ad5792357ae36082022aa34548fb7ad105909eccc27305064f8f948714f462e1d239c3af7f9b75b84f5658bcb03231d7d1d3b0ebc8025c96d2e7835f1bfb SHA512 b52fec3a85984708660dd454f5569900a5cce7804d02e719bddbdc7ed2f9f4ab1131e55b0a01ae977b18bb0bbd079e13ec887d5df108d8abfebdd04ad56e503f
DIST pyBigWig-0.3.4.tar.gz 59804 BLAKE2B 305f63925428332095341d69ed77c50b337bab9dcbc7c15ee68112b0d1ecba6d1b051a08fee7af16fe470dc8bdf1417fac2213ad50f1a6c0ab843dcc4c5f8e42 SHA512 9d7c174aa9d8242a5fb88a9a696201c7b5637ac66ae1aef730a5c4cc695f150094d830e0d575614f3f4a5cdf177bbc37a9fe06ced7ccc866906420288e24f319
diff --git a/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild b/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild
new file mode 100644
index 000000000..9ab75f89b
--- /dev/null
+++ b/dev-python/pyBigWig/pyBigWig-0.3.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="quick access to and creation of bigWig files"
+HOMEPAGE="https://github.com/dpryan79/pyBigWig"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dpryan79/pyBigWig"
+else
+ SRC_URI="https://github.com/dpryan79/pyBigWig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="sci-biology/libBigWig"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyBigWig/pyBigWig-9999.ebuild b/dev-python/pyBigWig/pyBigWig-9999.ebuild
index 169e6198f..9ab75f89b 100644
--- a/dev-python/pyBigWig/pyBigWig-9999.ebuild
+++ b/dev-python/pyBigWig/pyBigWig-9999.ebuild
@@ -1,20 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_5 )
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
-inherit git-r3 distutils-r1
-
-DESCRIPTION="Python extension written in C for quick access to and creation of bigWig files"
+DESCRIPTION="quick access to and creation of bigWig files"
HOMEPAGE="https://github.com/dpryan79/pyBigWig"
-EGIT_REPO_URI="https://github.com/dpryan79/pyBigWig.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dpryan79/pyBigWig"
+else
+ SRC_URI="https://github.com/dpryan79/pyBigWig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
DEPEND="sci-biology/libBigWig"
RDEPEND="${DEPEND}"