aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Wojciechowski <mrkwjc@gmail.com>2016-03-01 11:48:04 +0100
committerDavid Seifert <soap@gentoo.org>2016-03-21 22:42:30 +0100
commit6f5ee6f8ca095ce0c649cd3b55da9899874b9c22 (patch)
tree42f8850b05230456a090e002a7417aaab4defc83 /dev-python
parentMerge pull request #604 from olifre/genfit-git (diff)
downloadsci-6f5ee6f8ca095ce0c649cd3b55da9899874b9c22.tar.gz
sci-6f5ee6f8ca095ce0c649cd3b55da9899874b9c22.tar.bz2
sci-6f5ee6f8ca095ce0c649cd3b55da9899874b9c22.zip
dev-python/ffnet: Add new ffnet and ffnetui ebuilds
* Add new ffnet-0.8.3.ebuild. * Add dev-python/ffnetui - GUI for ffnet * Update ffnet, ffnetui ebuilds formatting * Update ffnetui header * dev-python/ffnet: Switch to EAPI=6 and other repoman suggestions * dev-python/ffnetui: Switch to EAPI=6 and other repoman suggestions * dev-python/ffnet: Update inherit line and examples instalation * dev-python/ffnet: Update metadata * dev-python/ffnetui: Update metadata * dev-python/ffnetui: Drop flag-o-matic and toolchain-funcs
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ffnet/Manifest1
-rw-r--r--dev-python/ffnet/ffnet-0.7.1.ebuild11
-rw-r--r--dev-python/ffnet/ffnet-0.8.3.ebuild41
-rw-r--r--dev-python/ffnet/metadata.xml4
-rw-r--r--dev-python/ffnetui/Manifest1
-rw-r--r--dev-python/ffnetui/ffnetui-0.8.3.2.ebuild24
-rw-r--r--dev-python/ffnetui/metadata.xml14
7 files changed, 87 insertions, 9 deletions
diff --git a/dev-python/ffnet/Manifest b/dev-python/ffnet/Manifest
index e025a1bb6..1eeebcd6f 100644
--- a/dev-python/ffnet/Manifest
+++ b/dev-python/ffnet/Manifest
@@ -1 +1,2 @@
DIST ffnet-0.7.1.tar.gz 58608 SHA256 42757113e8c04e32fe07f7e950f6be2d3a88d2ddd71351970bc417d136a1344f SHA512 eafb961716020f473b0cad6c37bdef42e9eb487076fd2b4b263ca045ad4db83441bb85acffa0068f3a1149c9f99a8d6919d27e0e33d40d9db9627448aac02ae3 WHIRLPOOL e47f0e372eb56fea15bd780d3529eca8281a0ebc7c6cdc5017735d900ab264de73df4a5a0ce68a5f23a80d26b7c87833c451087343894d9f6665b1772bea247c
+DIST ffnet-0.8.3.tar.gz 69148 SHA256 4d7befca0247108fc05fb7ebe7cdcff78eb642c4ab8c93215f592dcfed0f29f6 SHA512 acd5b3a4c094e803f12247cf9ddf8268fb7d3a22e68f89e2cca1bf0f9f9bd95d2806861c5a6183f1e62f484fb1423d2163ac19095fc9d48a7e924386f8ea24ea WHIRLPOOL f753a900410661b2efbf8adc69c215500056950989b818c8fb4ab4acd1b258f4459b5e497d5d1f4151492cad40c5a890d940d6f00ddc664bde2d2839b22fd1c5
diff --git a/dev-python/ffnet/ffnet-0.7.1.ebuild b/dev-python/ffnet/ffnet-0.7.1.ebuild
index 6e11d3dec..0eb1e128f 100644
--- a/dev-python/ffnet/ffnet-0.7.1.ebuild
+++ b/dev-python/ffnet/ffnet-0.7.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 flag-o-matic fortran-2 toolchain-funcs
+inherit distutils-r1 fortran-2 flag-o-matic
DESCRIPTION="Feed-forward neural network for python"
HOMEPAGE="http://ffnet.sourceforge.net/"
@@ -38,8 +38,5 @@ src_compile() {
python_install_all() {
distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
+ use examples && dodoc -r examples
}
diff --git a/dev-python/ffnet/ffnet-0.8.3.ebuild b/dev-python/ffnet/ffnet-0.8.3.ebuild
new file mode 100644
index 000000000..50d1a39d0
--- /dev/null
+++ b/dev-python/ffnet/ffnet-0.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_{6,7} python3_{3,4} )
+
+inherit distutils-r1 fortran-2 flag-o-matic
+
+DESCRIPTION="Feed-forward neural network for python"
+HOMEPAGE="http://ffnet.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples matplotlib"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ export FCONFIG="config_fc --noopt --noarch"
+ append-ldflags -shared
+ append-fflags -fPIC
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile ${FCONFIG}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}
diff --git a/dev-python/ffnet/metadata.xml b/dev-python/ffnet/metadata.xml
index 0de181947..e40054cae 100644
--- a/dev-python/ffnet/metadata.xml
+++ b/dev-python/ffnet/metadata.xml
@@ -7,12 +7,12 @@
</maintainer>
<longdescription lang="en">
ffnet is a fast and easy-to-use feed-forward neural
- network training solution for python.
+ network training library for python.
</longdescription>
<use>
<flag name="matplotlib">Use matplotlib for drawing</flag>
</use>
<upstream>
- <remote-id type="sourceforge">ffnet</remote-id>
+ <remote-id type="github">mrkwjc/ffnet</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/ffnetui/Manifest b/dev-python/ffnetui/Manifest
new file mode 100644
index 000000000..79fefae9c
--- /dev/null
+++ b/dev-python/ffnetui/Manifest
@@ -0,0 +1 @@
+DIST ffnetui-0.8.3.2.tar.gz 286481 SHA256 6a5db3e43bafc55f0abe6cbd9b368ea80c03c76bcb9e86fe89be7374151e25f3 SHA512 3749fdb817644502f4ef46515f9c9ad4bbd94e14b9a1e6340cdc3875dc2a4580b963b70a65dedc313948c90a19e4356fd46a8c14f163798cfa8e155f0f147192 WHIRLPOOL 229911022b162c5f7416e991391b857d2ea300248bdd3124abe5a2781e311485b1fb139c0f2b228e49cae912866783b912adf9e18794d3a5413ca215bc55552a
diff --git a/dev-python/ffnetui/ffnetui-0.8.3.2.ebuild b/dev-python/ffnetui/ffnetui-0.8.3.2.ebuild
new file mode 100644
index 000000000..9549ca462
--- /dev/null
+++ b/dev-python/ffnetui/ffnetui-0.8.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="GUI for ffnet - feed forward neural network for python"
+HOMEPAGE="http://ffnet.sourceforge.net"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-python/ffnet-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.4[${PYTHON_USEDEP}]
+ dev-python/traitsui[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/ffnetui/metadata.xml b/dev-python/ffnetui/metadata.xml
new file mode 100644
index 000000000..6e1e5f91c
--- /dev/null
+++ b/dev-python/ffnetui/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ GUI for ffnet - feed forward neural network for python
+</longdescription>
+ <upstream>
+ <remote-id type="github">mrkwjc/ffnetui</remote-id>
+ </upstream>
+</pkgmetadata>