aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Vig <sean.v.775@gmail.com>2015-09-02 12:08:15 -0500
committerSean Vig <sean.v.775@gmail.com>2015-09-03 08:16:02 -0500
commit7e3a5d2d4ae047332e0dbc90f7e80913573ece8c (patch)
tree890d7edabbb80ee696e27b426096ab37d5d7efc3 /dev-python
parentdev-python/jupyter_client: Fix testing deps (diff)
downloadsci-7e3a5d2d4ae047332e0dbc90f7e80913573ece8c.tar.gz
sci-7e3a5d2d4ae047332e0dbc90f7e80913573ece8c.tar.bz2
sci-7e3a5d2d4ae047332e0dbc90f7e80913573ece8c.zip
dev-python/jupyter_console: Fix testing deps
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyter_console/ChangeLog3
-rw-r--r--dev-python/jupyter_console/jupyter_console-9999.ebuild2
2 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/ChangeLog b/dev-python/jupyter_console/ChangeLog
index 77d9c663e..f56aa3b96 100644
--- a/dev-python/jupyter_console/ChangeLog
+++ b/dev-python/jupyter_console/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 02 Sep 2015; Sean Vig <sean.v.775@gmail.com> jupyter_console-9999.ebuild:
+ dev-python/jupyter_console: Fix testing deps
+
*jupyter_console-4.0.1 (01 Sep 2015)
01 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
diff --git a/dev-python/jupyter_console/jupyter_console-9999.ebuild b/dev-python/jupyter_console/jupyter_console-9999.ebuild
index 43b4766ff..a2a645f9c 100644
--- a/dev-python/jupyter_console/jupyter_console-9999.ebuild
+++ b/dev-python/jupyter_console/jupyter_console-9999.ebuild
@@ -29,6 +29,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pexpect[${PYTHON_USEDEP}]
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)