aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-08 15:06:43 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-08 15:07:33 +0100
commit7f5db31ee9ef324e9b13d05cc14c90ce8eeda040 (patch)
tree710f156d6030a239991dbee9f7552f3d9087d7e5 /dev-python
parentdev-python/numba: update manifests. (diff)
downloadsci-7f5db31ee9ef324e9b13d05cc14c90ce8eeda040.tar.gz
sci-7f5db31ee9ef324e9b13d05cc14c90ce8eeda040.tar.bz2
sci-7f5db31ee9ef324e9b13d05cc14c90ce8eeda040.zip
dev-python/pyparsing: add pyparsing-2
dep of fsleyes, cleaned from ::gentoo Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/metadata.xml21
-rw-r--r--dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild29
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
new file mode 100644
index 000000000..736d09882
--- /dev/null
+++ b/dev-python/pyparsing/Manifest
@@ -0,0 +1 @@
+DIST pyparsing_2.4.7.tar.gz 648158 BLAKE2B 24525b4ee7876e245b9eb270f0e3e22fe2d8b398f9777ad3b3657b8a1227dcbd25983aa64a3f3018debdbffc1a042c732e6b3a09800e081c7acac7b97da15317 SHA512 c7a546729f86a2b5176e2482b566b9fd715b03e495aaef4d720b21307bb03f385dbc849247f8d266cb3d92be0a83c34ce4995b655ce85318355d5a0d42d6991e
diff --git a/dev-python/pyparsing/metadata.xml b/dev-python/pyparsing/metadata.xml
new file mode 100644
index 000000000..2692e21d7
--- /dev/null
+++ b/dev-python/pyparsing/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The pyparsing module is an alternative approach to creating and
+ executing simple grammars, vs. the traditional lex/yacc approach, or the
+ use of regular expressions. The pyparsing module provides a library of
+ classes that client code uses to construct the grammar directly in
+ Python code.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="sourceforge">pyparsing</remote-id>
+ <remote-id type="pypi">pyparsing</remote-id>
+ <remote-id type="github">pyparsing/pyparsing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
new file mode 100644
index 000000000..55da214a2
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.4.7-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2004-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}