aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:40:23 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-25 18:40:23 +0100
commit82ce0f2237dd001066f6dd9d63589ed0b0428c14 (patch)
treefb2415643053decf5de31b17a28c72f226c554df /dev-python
parentdev-python/pyvote: bump python_compat (diff)
downloadsci-82ce0f2237dd001066f6dd9d63589ed0b0428c14.tar.gz
sci-82ce0f2237dd001066f6dd9d63589ed0b0428c14.tar.bz2
sci-82ce0f2237dd001066f6dd9d63589ed0b0428c14.zip
dev-python/reproject: bump to 0.8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/reproject/Manifest2
-rw-r--r--dev-python/reproject/reproject-0.8.ebuild (renamed from dev-python/reproject/reproject-0.7.1.ebuild)15
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-python/reproject/Manifest b/dev-python/reproject/Manifest
index 848284dcf..76c6dd3c9 100644
--- a/dev-python/reproject/Manifest
+++ b/dev-python/reproject/Manifest
@@ -1 +1 @@
-DIST reproject-0.7.1.tar.gz 770363 BLAKE2B 6df020b3cf594993a8660e335e528e9edd58c6104c546c01cb6a7a55df6f9ba6888a702c447a494065aa7da3aff7532ac6fd4f301f7f324976e6e0e3f001b0ce SHA512 7316a0b7bbf0dca9991b3298d0f5f308c4d88ba0c31b3cad28058d963ceac8fbb4b2d35d8fab1f379d767024159bbdb7408c18161bf3790325e599c75e603114
+DIST reproject-0.8.tar.gz 774255 BLAKE2B bf66cf2038f436567b6b0a66cc19608c96f98d2bf1624aa33c7b07e1e42c8bfdecc46072d410699f2a0c2f3db52a0ee04d0ce64f58464fd1abd28e33d704933d SHA512 48fba585de3fc67fdb39390390021e6e8295297e31d2c3fccbead53a592f512232ef182e8914906f21190108f87266faf5ad57d5982a76a50c30eeca630fd6ed
diff --git a/dev-python/reproject/reproject-0.7.1.ebuild b/dev-python/reproject/reproject-0.8.ebuild
index 33ca7691c..2daccec83 100644
--- a/dev-python/reproject/reproject-0.7.1.ebuild
+++ b/dev-python/reproject/reproject-0.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -28,10 +28,11 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/astropy-3.2[${PYTHON_USEDEP}]
- dev-python/astropy-healpix[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/astropy-healpix-0.6[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.1[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-astropy dev-python/matplotlib
+# requires self to be installed
+# distutils_enable_sphinx docs dev-python/sphinx-astropy dev-python/matplotlib
distutils_enable_tests --install pytest