aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-07 02:05:38 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-07 02:05:38 +0000
commit8b785ec12a5f715bde7300d252b7f349c6a07bcd (patch)
treebd12a43338cbef1de09bd21715fc973895f50569 /dev-python
parentdev-python/py2bit: undo drop dead package (diff)
downloadsci-8b785ec12a5f715bde7300d252b7f349c6a07bcd.tar.gz
sci-8b785ec12a5f715bde7300d252b7f349c6a07bcd.tar.bz2
sci-8b785ec12a5f715bde7300d252b7f349c6a07bcd.zip
dev-python/py2bit: version bump to 0.3.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/py2bit/Manifest1
-rw-r--r--dev-python/py2bit/py2bit-0.3.0.ebuild25
-rw-r--r--dev-python/py2bit/py2bit-9999.ebuild25
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/py2bit/Manifest b/dev-python/py2bit/Manifest
index d2694e454..ebf16d5a3 100644
--- a/dev-python/py2bit/Manifest
+++ b/dev-python/py2bit/Manifest
@@ -1 +1,2 @@
DIST py2bit-0.2.1.tar.gz 15206 BLAKE2B 75d8c7bd1bfb7224679538196d678a48f610c4de062df6caf78eb9100d8f6c5e68d7d233e3fd801d7128b52a06b36c18a573a6fcd2676a882cef11fe9035203e SHA512 b6a6a52488c432622df757e794b15ff8348e019b1547f750c9f66217fbe07758b6577261a28d8d75f81f63b2edf6b6b5d93b92ece60a64e0b5985407ea42e2fc
+DIST py2bit-0.3.0.tar.gz 16059 BLAKE2B b66621b91db8c0370933d1531c25e3e9d2cf34cc453e085f5acf92175f16bc4a87368d5b97f4ad1f6b0aeb715ac91e02f752f27d660e733cbcf9788f7fb9ff0b SHA512 914ee4490605a005c5c83e914e5d469dcb860a76cf52dd2337086954d9a37f21addca7a581eb8ff612b77f7969334057de4ab5d5ce2c6e15fb88e56abd36e193
diff --git a/dev-python/py2bit/py2bit-0.3.0.ebuild b/dev-python/py2bit/py2bit-0.3.0.ebuild
new file mode 100644
index 000000000..e39934379
--- /dev/null
+++ b/dev-python/py2bit/py2bit-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for accessing 2bit files"
+HOMEPAGE="https://github.com/dpryan79/py2bit"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dpryan79/py2bit"
+else
+ SRC_URI="https://github.com/dpryan79/py2bit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="sci-libs/lib2bit"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/py2bit/py2bit-9999.ebuild b/dev-python/py2bit/py2bit-9999.ebuild
new file mode 100644
index 000000000..e39934379
--- /dev/null
+++ b/dev-python/py2bit/py2bit-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for accessing 2bit files"
+HOMEPAGE="https://github.com/dpryan79/py2bit"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dpryan79/py2bit"
+else
+ SRC_URI="https://github.com/dpryan79/py2bit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="sci-libs/lib2bit"
+RDEPEND="${DEPEND}"