aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-03 08:31:03 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-03 08:31:03 +0100
commit9909afafdb9beef28ae10121c08e48105f3c51f0 (patch)
tree46ff91cb8f491948edad6f15830f7d8ed5b77782 /dev-python
parentsci-misc/elmer-gui: Make x11-libs/qwt an optional dependency (diff)
parentMerge branch 'master' into billyonthemountain-master (diff)
downloadsci-9909afafdb9beef28ae10121c08e48105f3c51f0.tar.gz
sci-9909afafdb9beef28ae10121c08e48105f3c51f0.tar.bz2
sci-9909afafdb9beef28ae10121c08e48105f3c51f0.zip
Merge branch 'billyonthemountain-master' into asd
* billyonthemountain-master: sci-libs/elmer-eio: Bump EAPI; fix license; fix DESCRIPTION; drop keywords from live ebuild; use correct phase functions; simplify configure dev-python/pythonqt: Add metadata.xml; bump to new pyhton eclasses; fix patch for multilib to do it the gentoo way; drop '.' from DESCRIPTION; add missing deps sci-misc/elmer-gui: Make x11-libs/qwt an optional dependency sci-libs/opencascade: Verion bump dev-python/pythonqt: New package sci-mathematics/netgen: Version bump sci-misc/elmer-meta: New ebuilds for Elmer FEM packages Signed-off-by: Justin Lecher <jlec@gentoo.org> Conflicts: dev-python/pythonqt/Manifest dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch dev-python/pythonqt/files/pythonqt-9999-lib_location.patch dev-python/pythonqt/pythonqt-2.1.ebuild dev-python/pythonqt/pythonqt-9999.ebuild sci-libs/elmer-eio/Manifest sci-libs/elmer-eio/elmer-eio-9999.ebuild
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pythonqt/ChangeLog11
-rw-r--r--dev-python/pythonqt/Manifest1
-rw-r--r--dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch6
-rw-r--r--dev-python/pythonqt/files/pythonqt-9999-lib_location.patch6
-rw-r--r--dev-python/pythonqt/metadata.xml5
-rw-r--r--dev-python/pythonqt/pythonqt-1.1.ebuild75
-rw-r--r--dev-python/pythonqt/pythonqt-2.1.ebuild29
-rw-r--r--dev-python/pythonqt/pythonqt-9999.ebuild28
8 files changed, 59 insertions, 102 deletions
diff --git a/dev-python/pythonqt/ChangeLog b/dev-python/pythonqt/ChangeLog
new file mode 100644
index 000000000..731422ef1
--- /dev/null
+++ b/dev-python/pythonqt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/pythonqt
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Dec 2013; Justin Lecher <jlec@gentoo.org> -pythonqt-1.1.ebuild,
+ pythonqt-2.1.ebuild, pythonqt-9999.ebuild,
+ files/pythonqt-2.1-lib_location.patch,
+ files/pythonqt-9999-lib_location.patch, +metadata.xml:
+ Add metadata.xml; bump to new pyhton eclasses; fix patch for multilib to do
+ it the gentoo way; drop '.' from DESCRIPTION; add missing deps
+
diff --git a/dev-python/pythonqt/Manifest b/dev-python/pythonqt/Manifest
index d37dedbe4..931ad5df0 100644
--- a/dev-python/pythonqt/Manifest
+++ b/dev-python/pythonqt/Manifest
@@ -1,2 +1 @@
-DIST PythonQt-1.1.zip 507747 SHA256 901096018f07fc81ab11a9f29c61cf1cb8a4b47721b8250b0ccc6e904590f5a9 SHA512 f48fa2cfe809854547050b45da8af6c8d2cb2c36e0f787541f815460da2a8bccaef44dece92172b3af25b3c9846105d97f38721dc6f2ed5f4fe4a19ffb92acb2 WHIRLPOOL b6aa1f9ebec2a16db8ddc1b01720a7bdaf6ed44e2db138c806b7de70390a8019f6985a8010440716b8b9a5fa5a3907c43feddadb4de2966641992eaf9549e50d
DIST PythonQt2.1_Qt4.8.zip 1390321 SHA256 b0885a02d26e8e2caaccfdf5d31fe5e5f7681a7a257e527889135a2cc4add381 SHA512 3f74818db754030fdeec8b19da053a7042b42d6dd681c25dd5b4dbcbb30e200e83843c7311c6944e0faf66e2f5cf2144b7c4410272c57342d47a95e957935546 WHIRLPOOL eef318f7e4f90e658ca8d96545d5d6d0c5ea2f1e7e4f3854dfaf9c52116d109107c292fa9f5180d8f5d9e1bafc30cd0efff512015bfd68a70b3798e2b16fcfe4
diff --git a/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch b/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
index 41d4dbfb0..dd3bcc624 100644
--- a/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
+++ b/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
@@ -5,7 +5,7 @@
#
set_target_properties(PythonQt PROPERTIES
- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
-+ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib64"
++ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
)
target_link_libraries(PythonQt
@@ -15,8 +15,8 @@
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib64
-+ ARCHIVE DESTINATION lib64)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
install(FILES ${headers} DESTINATION include/PythonQt)
MESSAGE(STATUS "<<< Gentoo configuration >>>
diff --git a/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch b/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
index 5f810c562..111db4780 100644
--- a/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
+++ b/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
@@ -5,7 +5,7 @@
#
set_target_properties(PythonQt PROPERTIES
- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
-+ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib64"
++ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
)
target_link_libraries(PythonQt
@@ -15,6 +15,6 @@
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib64
-+ ARCHIVE DESTINATION lib64)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
install(FILES ${headers} DESTINATION include/PythonQt)
diff --git a/dev-python/pythonqt/metadata.xml b/dev-python/pythonqt/metadata.xml
new file mode 100644
index 000000000..897aa2e6b
--- /dev/null
+++ b/dev-python/pythonqt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/dev-python/pythonqt/pythonqt-1.1.ebuild b/dev-python/pythonqt/pythonqt-1.1.ebuild
deleted file mode 100644
index 90f52abfd..000000000
--- a/dev-python/pythonqt/pythonqt-1.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-inherit qt4-r2 python
-
-MY_PN="PythonQt"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A dynamic Python binding for the Qt framework."
-HOMEPAGE="http://pythonqt.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${MY_PN}%20${PV}/${MY_P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="examples extensions test"
-
-DEPEND="dev-lang/python
- x11-libs/qt-core
- x11-libs/qt-gui"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare(){
- sed -i \
- -e "s|unix:LIBS +=.*|unix:LIBS += $(python_get_library -l)|" \
- -e "s|unix:QMAKE_CXXFLAGS +=.*|unix:QMAKE_CXXFLAGS += -I$(python_get_includedir)|" \
- build/python.prf || die
-
- # Don't build examples and tests
- sed -i \
- -e 's/examples//' \
- -e 's/tests//' \
- ${MY_PN}.pro || die
-
- if use !extensions; then
- sed -i 's/extensions//' ${MY_PN}.pro || die
- fi
-}
-
-src_configure() {
- eqmake4 "${S}" ./${MY_PN}.pro
-}
-
-src_install(){
- dodir /usr/include/${MY_PN}/{gui,wrapper}
-
- insinto /usr/include/${MY_PN}
- doins src/*.h
-
- insinto /usr/include/${MY_PN}/gui
- doins src/gui/*.h
-
- if use extensions; then
- insinto /usr/include/${MY_PN}/gui
- doins extensions/PythonQtGui/*.h
- fi
-
- insinto /usr/include/${MY_PN}/wrapper
- doins src/wrapper/*.h
-
- dolib.so lib/*.so*
-
- dodoc CHANGELOG.txt COPYING README
- dohtml doxygen/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/pythonqt/pythonqt-2.1.ebuild b/dev-python/pythonqt/pythonqt-2.1.ebuild
index 34b993445..99e078608 100644
--- a/dev-python/pythonqt/pythonqt-2.1.ebuild
+++ b/dev-python/pythonqt/pythonqt-2.1.ebuild
@@ -1,27 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit cmake-utils
+PYTHON_COMPAT=( python{2_6,2_7} )
-DESCRIPTION="A dynamic Python binding for the Qt framework."
+inherit cmake-utils python-single-r1
+
+MY_PN="PythonQt"
+MY_P="${MY_PN}${PV}"
+
+DESCRIPTION="A dynamic Python binding for the Qt framework"
HOMEPAGE="http://pythonqt.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pythonqt/pythonqt/PythonQt-2.1/PythonQt2.1_Qt4.8.zip"
+SRC_URI="mirror://sourceforge/pythonqt/pythonqt/${MY_PN}-${PV}/${MY_P}_Qt4.8.zip"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/PythonQt${PV}_Qt4.8"
-CMAKE_BUILD_DIR="${S}"
+S="${WORKDIR}/${MY_P}_Qt4.8"
-src_prepare()
-{
- use amd64 && epatch "${FILESDIR}/${P}-lib_location.patch"
-}
+PATCHES=( "${FILESDIR}"/${P}-lib_location.patch )
diff --git a/dev-python/pythonqt/pythonqt-9999.ebuild b/dev-python/pythonqt/pythonqt-9999.ebuild
index d7d6bfd83..1444bd420 100644
--- a/dev-python/pythonqt/pythonqt-9999.ebuild
+++ b/dev-python/pythonqt/pythonqt-9999.ebuild
@@ -1,13 +1,19 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit cmake-utils subversion
+PYTHON_COMPAT=( python{2_6,2_7} )
-DESCRIPTION="A dynamic Python binding for the Qt framework."
+inherit cmake-utils python-single-r1 subversion
+
+MY_PN="PythonQt"
+MY_P="${MY_PN}${PV}"
+
+DESCRIPTION="A dynamic Python binding for the Qt framework"
HOMEPAGE="http://pythonqt.sourceforge.net/"
+SRC_URI=""
ESVN_REPO_URI="https://pythonqt.svn.sourceforge.net/svnroot/pythonqt/trunk"
LICENSE="LGPL-2.1"
@@ -15,10 +21,16 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
RDEPEND="${DEPEND}"
-src_prepare()
-{
- use amd64 && epatch "${FILESDIR}/${P}-lib_location.patch"
+PATCHES=( "${FILESDIR}"/${P}-lib_location.patch )
+
+src_prepare() {
+ subversion_src_prepare
+ cmake-utils_src_prepare
}