aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-03-06 16:11:28 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2017-03-06 16:11:28 +0100
commitbc64dbbfbcb91ea65d47f631ce2465c3c4d8d487 (patch)
tree54ea8ed48b996f90d63f1111fe986cbb93c2cdb9 /dev-python
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-bc64dbbfbcb91ea65d47f631ce2465c3c4d8d487.tar.gz
sci-bc64dbbfbcb91ea65d47f631ce2465c3c4d8d487.tar.bz2
sci-bc64dbbfbcb91ea65d47f631ce2465c3c4d8d487.zip
dev-python/arrayfire-python: Version bump to 3.4.20170222
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/arrayfire-python/Manifest1
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/arrayfire-python/Manifest b/dev-python/arrayfire-python/Manifest
index 573de02f2..2a75b3d63 100644
--- a/dev-python/arrayfire-python/Manifest
+++ b/dev-python/arrayfire-python/Manifest
@@ -2,3 +2,4 @@ DIST arrayfire-3.1.20151111.tar.gz 35015 SHA256 6992ac07645dbafbfda0c73a2c3eb94b
DIST arrayfire-3.2.20151224.tar.gz 39158 SHA256 446a8a1e74f2271f0f8cafcc4d144a1cd58d01de50b6f90cc0c2ef48d044434d SHA512 bd3bdab84835c1e112e4d7d159f76d02a0291bc1a82928918202abd524b296b47589dec7d432419006c0348e0741d07e7852d1ad943ae2640b78be3c057f94ed WHIRLPOOL c88e019ed288a05c78de7cd44f590b751c71ebecf957eed7c71d697c3fa026816f4731190de942c73b113c4f98d8f0de8274df619e97ac4c0f8da12b9ad73013
DIST arrayfire-python-3.3.20160624.tar.gz 104485 SHA256 736397518dab08dedcd1b13b287548f5171319e63c9db15b6aa3e141689295e2 SHA512 e311470287c099b54961cf7988b57b2c0e3f36b4c77deabcd2ac934f8f3f81d39a97dfe3d10e677a1a58f71d6944010595ac8d30de054b2a7edbe19d599e87d1 WHIRLPOOL 1de41d1a1374a72f3c4801fa48a2c3162f53e95d2688bd2befe68000870eb04382b42812614ff4e1346d63feba336829b88ce87e9f51803e03d584c8061e9489
DIST arrayfire-python-3.4.20161126.tar.gz 108299 SHA256 24c8184fa3a6d5681efe1be460b70865d213367976567b026c947e7ac1379dfd SHA512 819d06b3a42922f70352f37a5d1d312c896f8975584cbe8d2bd671e26fc7725247b2826a53ecbcfc00ad4f05c305651a6673fbd89e1d686b514c91d4276820cb WHIRLPOOL 0130599bf05b284a1cdfb1237df05535da19c0a4f3c938f3cefe0117a31e7ea042d3e3730bc49e360aabbf1921c00d7a8020dfd9e4c7a0dafc3521217cfc08db
+DIST arrayfire-python-3.4.20170222.tar.gz 111992 SHA256 02b953f424cc743da52f369e9a556107362efc7930bfd7bc22e37c3599886560 SHA512 a9c41c7932592df15a023c41d920bd9588da55a58db456d42e2c5b707645564c48aef26ae99345cae8053585a55a4b85b26750e998f2873f81b5d068afe29f71 WHIRLPOOL 00b5f04d0e4d878f87abd0e1012f6c1e6ee6ea4fca5f6e08872cdbe76432bc384c954c4a0da8ec262b8494b77b64bb59556a6abf796e74bd9c452f0cae9c93a9
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild
new file mode 100644
index 000000000..32818eef8
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-3.4.20170222.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+SRC_URI="https://github.com/arrayfire/arrayfire-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=sci-libs/arrayfire-3.4.0
+ <sci-libs/arrayfire-3.5.0
+ "
+DEPEND="${RDEPEND}"
+
+python_test() {
+ ${EPYTHON} -m arrayfire.tests
+}