aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-05-17 17:35:13 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-05-17 17:35:13 +0200
commitcf2c278eac8ce6a6beead6e42595ab183dac7221 (patch)
tree8e9176ca784ddeeeb505b484ab0d8c33bc428280 /dev-python
parentdev-python/ipywidgets: Bump to EAPI=6 (diff)
downloadsci-cf2c278eac8ce6a6beead6e42595ab183dac7221.tar.gz
sci-cf2c278eac8ce6a6beead6e42595ab183dac7221.tar.bz2
sci-cf2c278eac8ce6a6beead6e42595ab183dac7221.zip
dev-python/ipywidgets: Version bump to 5.1.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-5.1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 4905000a4..86b37ed1d 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-4.1.1.tar.gz 321646 SHA256 ceeb325e45ade9537c2d115fed9d522e5c6e90bb161592e2f0807375dc661028 SHA512 53b18ae432f72d3305333e92f488f62bb36f83d37fab59e4d103fb77a7ee266d03b96e6de4ffcc2a0f67d6fd892ed1d984c0b188d6cbd527ff3e950e885a5fe4 WHIRLPOOL e1ccb54416bd48fa451cd84f818595dcbe907a3bda79935d884b6f1f226167559cc24f1390d35f8b9a1e3a9af07da5c755c05e93729e27573d030d7ba2def3c3
+DIST ipywidgets-5.1.3.tar.gz 2467318 SHA256 316f9d90121901dc7b1cbba67175f9d628a5e2fce076d0c45f54331a2c9ada87 SHA512 0deaf38fc579f710e9fedbf4141f4936c64f4d018e96988af6940f25f568fcd33c2e421dff091d8c7821186ce2947048639c01793a932881bcb83d7bd544de5e WHIRLPOOL 9ab4d7cfed63d03a289ebf38b53271faf07c4340292200dfd5d30d3b009ac50b29e077fb66c7a4b0dcb5042f3a8e73be65b7c76556b1d959a9ee497a5cd3761e
diff --git a/dev-python/ipywidgets/ipywidgets-5.1.3.ebuild b/dev-python/ipywidgets/ipywidgets-5.1.3.ebuild
new file mode 100644
index 000000000..f59b98c1b
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-5.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/traitlets-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.2.2[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-1.2.2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+}