aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 20:00:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 20:00:54 +0200
commitd22723191e8cbb104437511c1a9eb141a0247ef1 (patch)
treefb51ab01b4e29610c34c9e2e02de5c0623ebbb1f /dev-python
parentsci-biology/nilearn: drop version 0.6.2 (diff)
downloadsci-d22723191e8cbb104437511c1a9eb141a0247ef1.tar.gz
sci-d22723191e8cbb104437511c1a9eb141a0247ef1.tar.bz2
sci-d22723191e8cbb104437511c1a9eb141a0247ef1.zip
dev-python/jupyterlab: also clean upon pkg_prerm
and include the licenses of the js stuff Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.1.10.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild b/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild
index 415bfa0ad..6940fff45 100644
--- a/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild
+++ b/dev-python/jupyterlab/jupyterlab-3.1.10.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="JupyterLab computational environment"
HOMEPAGE="https://jupyter.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="BSD"
+LICENSE="BSD MIT GPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
@@ -34,5 +34,10 @@ distutils_enable_tests pytest
#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
pkg_postinst() {
- jupyter-lab build || die "Failed to build jupyter assets"
+ # We have to do this here because we need internet since this uses yarn
+ jupyter-lab build -y || die "Failed to build jupyterlab javascript assets"
+}
+
+pkg_prerm() {
+ jupyter-lab clean -y || die "Failed to clean jupyterlab javascript assets"
}