aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-26 11:09:40 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-26 11:09:40 +0100
commitd31527554d69845839e97a0a54686d4072052e77 (patch)
tree38aeb1d75b7b9790bb1afc66e3fe083a448ef181 /dev-python
parentsci-biology/bambus: fix PMS violation (diff)
downloadsci-d31527554d69845839e97a0a54686d4072052e77.tar.gz
sci-d31527554d69845839e97a0a54686d4072052e77.tar.bz2
sci-d31527554d69845839e97a0a54686d4072052e77.zip
dev-python/sphinx-argparse: bump to 0.3.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-argparse/Manifest2
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.2.5.ebuild41
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.3.1.ebuild27
3 files changed, 28 insertions, 42 deletions
diff --git a/dev-python/sphinx-argparse/Manifest b/dev-python/sphinx-argparse/Manifest
index a0e62eccf..cc6a6ba19 100644
--- a/dev-python/sphinx-argparse/Manifest
+++ b/dev-python/sphinx-argparse/Manifest
@@ -1 +1 @@
-DIST sphinx-argparse-0.2.5.tar.gz 24890 BLAKE2B 870329d588c5c1131bb104e548e6f1caf673b6b4ffa9cb074a9a6e769f90d8d351ec14ce05f902d10ce4ae2336e05a119a386ea154faf2a5c57ba240514c9b92 SHA512 8e946947c9d018c10d7283b19c49cf19bf5813ba5c227bf3aac21752e5ecddf4653ec2bb1e2b67b8c1c3d8eb50ede55acc5b0e0071297433a2468606d3baa0b1
+DIST sphinx-argparse-0.3.1.tar.gz 42953 BLAKE2B 76c74a270a638b1b894548bc898918fbfa5fde6bcf1ccbf5e69a3daaada829bc1ae27ad8befd18e834646dc2fc3b025f36807c2be894911cc0c6d65294174898 SHA512 3d289c90165eb6a3d7a94dff8e6a429a49eb404ce373e80e007a0cd9abaae1e1236f5393df2fbf11701c349dade9d199640dc398064da4fd50a58a90eb3f8f12
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.2.5.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.2.5.ebuild
deleted file mode 100644
index 33cb3ae66..000000000
--- a/dev-python/sphinx-argparse/sphinx-argparse-0.2.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
-HOMEPAGE="https://pypi.org/project/sphinx-argparse/
- https://github.com/alex-rudakov/sphinx-argparse"
-SRC_URI="https://github.com/alex-rudakov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=""
-RDEPEND="
- ${DEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/commonmark[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-# requires self to build own documentation
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-argparse
-
-python_prepare_all() {
- # test fails, skip it until a fix is found:
- # AssertionError: assert [{'action_groups': [{'description': None,\n 'options': [{'default': None,\n
- sed -i -e 's:test_parse_nested:_&:' \
- -e 's:test_parse_nested_traversal:_&:' \
- test/test_parser.py || die
-
- # needs test files in workdir to compile docs for some reason
- cp -r test "${WORKDIR}/test/" || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.3.1.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.3.1.ebuild
new file mode 100644
index 000000000..5b380202e
--- /dev/null
+++ b/dev-python/sphinx-argparse/sphinx-argparse-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
+HOMEPAGE="https://pypi.org/project/sphinx-argparse/
+ https://github.com/ashb/sphinx-argparse"
+SRC_URI="https://github.com/ashb/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# requires self to build own documentation
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-argparse