aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorleycec <leycec@gmail.com>2021-08-07 01:26:13 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-07 09:31:22 +0200
commite3912eef6e96fbaadc99e118bc9f549260d014ab (patch)
tree6cd3d9ce57cab4fcfb432b75daf607e1c5309fe5 /dev-python
parentdev-python/ezdxf: add (diff)
downloadsci-e3912eef6e96fbaadc99e118bc9f549260d014ab.tar.gz
sci-e3912eef6e96fbaadc99e118bc9f549260d014ab.tar.bz2
sci-e3912eef6e96fbaadc99e118bc9f549260d014ab.zip
dev-python/cadquery: add
add a (reasonably) stable release candidate of CadQuery 2.2, a Python API generating CAD models via Open Cascade Technologies (OCCT) Signed-off-by: Cecil Curry <leycec@gmail.com> Closes: https://github.com/gentoo/sci/pull/1108 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cadquery/Manifest1
-rw-r--r--dev-python/cadquery/cadquery-2.2_rc20210804.ebuild56
-rw-r--r--dev-python/cadquery/metadata.xml12
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/cadquery/Manifest b/dev-python/cadquery/Manifest
new file mode 100644
index 000000000..ae1e31fa3
--- /dev/null
+++ b/dev-python/cadquery/Manifest
@@ -0,0 +1 @@
+DIST cadquery-2.2_rc20210804.tar.gz 2832275 BLAKE2B b1b25130a9eb73e4913c6e9fc8d1fafd689bc9d216adee6d7fcc6fd80805b9351e87839fae3d6bf7e0a1ccf147e5b4a9afe8f6afc0e01c1b3a287e2671870c8d SHA512 0c5b16da24deba2267b204e5f51f707fffab9a238b27af84a500b8a98aa190be24be75d7bc2d1e282c04aea7116eb404ed4520515d53ae5a64aebafc647aa4a3
diff --git a/dev-python/cadquery/cadquery-2.2_rc20210804.ebuild b/dev-python/cadquery/cadquery-2.2_rc20210804.ebuild
new file mode 100644
index 000000000..46025c4c0
--- /dev/null
+++ b/dev-python/cadquery/cadquery-2.2_rc20210804.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parametric CAD scripting framework based on OCCT"
+HOMEPAGE="https://cadquery.readthedocs.io"
+
+# The official CadQuery 2.1 tarball requires the obsolete OCCT 7.4.0, but
+# CadQuery 2.2 has yet to be officially released. We instead package a commit
+# known to work as expected with OCCT 7.5.2.
+MY_COMMIT="9b657093c30147293034068dd9d58ec2b728e61a"
+
+#FIXME: Uncomment on bumping to the next stable release.
+# SRC_URI="https://github.com/CadQuery/cadquery/archive/refs/tags/${PV}.tar.gz"
+SRC_URI="https://github.com/CadQuery/cadquery/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Dependencies are intentionally listed in "conda/meta.yml" order. Due to its
+# Anaconda focus, "setup.py" currently fails to list dependencies.
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ >=dev-python/cadquery-ocp-7.5.0[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pyparsing-2.0.0[${PYTHON_USEDEP}]
+ dev-python/ezdxf[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/nptyping[${PYTHON_USEDEP}]
+ sci-libs/nlopt[python,${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+distutils_enable_tests pytest
+
+#FIXME: Uncomment after packaging "dev-python/sphinx-autodoc-typehints".
+# distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinx-autodoc-typehints
diff --git a/dev-python/cadquery/metadata.xml b/dev-python/cadquery/metadata.xml
new file mode 100644
index 000000000..86166e277
--- /dev/null
+++ b/dev-python/cadquery/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">CadQuery/cadquery</remote-id>
+ </upstream>
+</pkgmetadata>