aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2022-01-16 23:16:01 +0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-16 16:22:26 +0100
commitebe960677718da5594d78b8c4ccb28006600678d (patch)
treedf5d3adbe1e231c716d6e9c5d5c4b3c0bd3abfad /dev-python
parentdev-python/astropy-healpix: remove unneeded dependency (diff)
downloadsci-ebe960677718da5594d78b8c4ccb28006600678d.tar.gz
sci-ebe960677718da5594d78b8c4ccb28006600678d.tar.bz2
sci-ebe960677718da5594d78b8c4ccb28006600678d.zip
dev-python/numba: bump version to 0.55.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/sci/pull/1137 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numba/Manifest1
-rw-r--r--dev-python/numba/numba-0.55.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/numba/Manifest b/dev-python/numba/Manifest
index 04302b8a6..05834c652 100644
--- a/dev-python/numba/Manifest
+++ b/dev-python/numba/Manifest
@@ -1 +1,2 @@
DIST numba-0.54.0.tar.gz 2263302 BLAKE2B 24747fcf23f686460fdd8df4784a3bccd6c41f07ff7e657f797a2959066254c079b05ec4460a7cbafef9482f463aa000ee28f8f09339cd7568a0c85b52bc4437 SHA512 ad1142e8c772660b7cbbd17566b9dc96784057467b5cc546f88e2215c9428905e1f6da05ffe104f4ad526f5131fedfa9057745d5458c3293a8cd8e01a49d0fad
+DIST numba-0.55.0.tar.gz 2335694 BLAKE2B 38b0b6f1aa0a903db4a3a8185d5e0b81a5eb87be8db3e5f176e3e2dcd0b1777a473826742d975de2ff7cb5acbd7c3fd3c2e8a5a9d1199cb335b95bc5b913b085 SHA512 cbf758c2b928537968dc70e2f6a97ff14ced0954b7b61a091ace921866adaa1ed17a31cc7d27aa43f071b32c473508e13eb56f1cb6473aeaa00c04f5e7484f86
diff --git a/dev-python/numba/numba-0.55.0.ebuild b/dev-python/numba/numba-0.55.0.ebuild
new file mode 100644
index 000000000..c700339ad
--- /dev/null
+++ b/dev-python/numba/numba-0.55.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit optfeature multiprocessing distutils-r1
+
+DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
+HOMEPAGE="https://numba.pydata.org/
+ https://github.com/numba"
+SRC_URI="https://github.com/numba/numba/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="openmp threads"
+
+RDEPEND="
+ >=dev-python/llvmlite-0.38.0[${PYTHON_USEDEP}]
+ <=dev-python/llvmlite-0.39.0
+ >=dev-python/numpy-1.18.0[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ threads? ( >=dev-cpp/tbb-2019.5 )
+"
+BDEPEND="
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+distutils_enable_tests unittest
+distutils_enable_sphinx docs/source dev-python/numpydoc dev-python/sphinx_rtd_theme
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.52.0-skip_tests.patch"
+)
+
+pkg_setup() {
+ if ! use openmp; then
+ export NUMBA_DISABLE_OPENMP=1 || die
+ else
+ unset NUMBA_DISABLE_OPENMP || die
+ fi
+ if ! use threads; then
+ export NUMBA_DISABLE_TBB=1 || die
+ else
+ unset NUMBA_DISABLE_TBB || die
+ export TBBROOT="${EPREFIX}/usr" || die
+ fi
+}
+
+python_prepare_all() {
+ # This conf.py only works in a git repo
+ if use doc; then
+ git init -q || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m "init" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # FIXME: parallel python building fails. See Portage bug #614464 and
+ # gentoo/sci issue #1080.
+ export MAKEOPTS=-j1 || die
+ distutils-r1_python_compile
+}
+
+# https://numba.pydata.org/numba-doc/latest/developer/contributing.html?highlight=test#running-tests
+python_test() {
+ distutils_install_for_testing
+ ${EPYTHON} setup.py build_ext --inplace || die \
+ "${EPYTHON} failed to build_ext"
+ ${EPYTHON} runtests.py -m $(makeopts_jobs) || die \
+ "${EPYTHON} failed unittests"
+}
+
+pkg_postinst() {
+ optfeature "compile cuda code" dev-util/nvidia-cuda-sdk
+}