aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-04 10:21:24 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-04 10:21:24 +0200
commit014f94688188babd8cbe02af6133391c1d9f9a0c (patch)
treecf6fe5a8510069bcfbcfc26b0623304949fc131c /dev-tcltk/togl/togl-2.0-r1.ebuild
parentcoot Upstream fixed the check maketarget (diff)
downloadsci-014f94688188babd8cbe02af6133391c1d9f9a0c.tar.gz
sci-014f94688188babd8cbe02af6133391c1d9f9a0c.tar.bz2
sci-014f94688188babd8cbe02af6133391c1d9f9a0c.zip
readded togl
Signed-off-by: Justin Lecher (jlec) <jlec@j-schmitz.net>
Diffstat (limited to 'dev-tcltk/togl/togl-2.0-r1.ebuild')
-rw-r--r--dev-tcltk/togl/togl-2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tcltk/togl/togl-2.0-r1.ebuild b/dev-tcltk/togl/togl-2.0-r1.ebuild
new file mode 100644
index 000000000..fe834587d
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_P="Togl${PV}"
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +threads"
+
+RDEPEND="dev-lang/tk
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable amd64 64bit) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dohtml doc/* || die "no html"
+ dodoc README* || die "no README"
+}