aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-13 20:01:46 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-13 20:01:46 +0200
commit75724311f67f206376ebdcfd5caa4c5e30681ea3 (patch)
tree18445b4c59caf1d11b8e1fcc06eb4de6f16040b4 /dev-tex/pythontex/pythontex-9999.ebuild
parentFinally works on all tested machines (creating the scripts normally, and the ... (diff)
downloadsci-75724311f67f206376ebdcfd5caa4c5e30681ea3.tar.gz
sci-75724311f67f206376ebdcfd5caa4c5e30681ea3.tar.bz2
sci-75724311f67f206376ebdcfd5caa4c5e30681ea3.zip
Created live ebuild to benefit from some fixes to the package which became obvious while writing the ebuildt.
Diffstat (limited to 'dev-tex/pythontex/pythontex-9999.ebuild')
-rw-r--r--dev-tex/pythontex/pythontex-9999.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-tex/pythontex/pythontex-9999.ebuild b/dev-tex/pythontex/pythontex-9999.ebuild
new file mode 100644
index 000000000..240c4be25
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2-r1.ebuild,v 1.18 2012/05/09 17:16:08 aballier Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit latex-package python-single-r1 git-2
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+EGIT_REPO_URI="https://github.com/TheChymera/pythontex.git"
+SRC_URI=""
+
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS=""
+IUSE="highlighting"
+
+DEPEND="app-text/texlive
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ S="${WORKDIR}/${P}/${PN}"
+ cd ${S}
+}
+
+src_compile() {
+ ebegin "Compiling ${PN}"
+ latex ${PN}.ins extra >/dev/null || die "Building style from ${PN}.ins failed"
+ eend
+}
+
+src_install() {
+ python_optimize .
+ if python_is_python3; then
+ #python_scriptinto /usr/share/texmf-site/scripts/${PN}/
+ python_newscript pythontex3.py pythontex.py
+ python_newscript depythontex3.py depythontex.py
+ else python_newscript pythontex2.py pythontex.py
+ python_doscript pythontex_2to3.py
+ python_newscript depythontex2.py depythontex.py
+ fi
+
+ python_moduleinto /usr/lib64/python-exec/python2.7
+ python_domodule "${S}"/pythontex_engines.py
+ python_domodule "${S}"/pythontex_utils.py
+
+ insinto /usr/share/texmf-site/tex/latex/pythontex/
+ doins "${S}"/pythontex.sty
+
+ insinto /usr/share/texmf-site/source/latex/pythontex/
+ doins "${S}"/pythontex.dtx
+ doins "${S}"/pythontex.ins
+
+ latex-package_src_install
+
+ dodoc README
+ mktexlsr
+}