aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-01 00:45:22 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-01 00:45:22 +0200
commit33398fa1b68185f52b249407f4f499db72749ea4 (patch)
tree78c5dcfedfdba7f2544289e0cd5e27ac93a91474 /dev-tex/pythontex
parentsci-chemistry/gamess: Update Manifest (diff)
downloadsci-33398fa1b68185f52b249407f4f499db72749ea4.tar.gz
sci-33398fa1b68185f52b249407f4f499db72749ea4.tar.bz2
sci-33398fa1b68185f52b249407f4f499db72749ea4.zip
New oythontex ebuild
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/Manifest1
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-tex/pythontex/Manifest b/dev-tex/pythontex/Manifest
new file mode 100644
index 000000000..1bc092444
--- /dev/null
+++ b/dev-tex/pythontex/Manifest
@@ -0,0 +1 @@
+DIST pythontex_0.12.zip 1537341 SHA256 5d37f59200fd4d41180dac7ebdf1d4c1ce276b25cb66483a8d64c6a285220579 SHA512 1e2fc36100be20b16fa25d987a6e4568724e6ab3edff3e9544dd90a14428b471e98ac29413aa9ef60e144aa963e6ef260932cad1903bb762d55421c35a0b69ff WHIRLPOOL 957a43e31f17f91386df739840cb0cb30d84db330c0b0e76e5602eb28ea24836569f72790d9dd6a8bdb26a6c073992a876db47102e46107467c349c0771f03bf
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
new file mode 100644
index 000000000..6c462744e
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2-r1.ebuild,v 1.18 2012/05/09 17:16:08 aballier Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit latex-package python-r1
+
+S="${WORKDIR}/${PN}"
+LICENSE="LPPL-1.3 BSD"
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/raw/master/package_downloads/${PN}_${PV}.zip https://github.com/gpoore/pythontex/raw/master/package_downloads/old_versions/${PN}_${PV}.zip"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="highlighting"
+
+DEPEND="app-text/texlive
+ dev-lang/python"
+
+RDEPEND="${DEPEND}
+ highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ ebegin "Compiling ${PN}"
+ latex ${PN}.ins || die
+ eend
+}
+
+src_install() {
+ latex-package_src_install
+
+ insinto ${TEXMF}/tex/latex/${PN}
+ doins *.cfg
+
+ dodoc README
+}