aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2013-10-06 00:57:04 +0200
committerHorea Christian <h.chr@mail.ru>2013-10-06 00:57:04 +0200
commit8a99be06291b2515447d38a95721be5c4fa5f92f (patch)
tree96e515f378672a796d7d03576532d3853667ef3b /dev-tex/pythontex
parentassed shebang fix an python optimize (diff)
downloadsci-8a99be06291b2515447d38a95721be5c4fa5f92f.tar.gz
sci-8a99be06291b2515447d38a95721be5c4fa5f92f.tar.bz2
sci-8a99be06291b2515447d38a95721be5c4fa5f92f.zip
Installying python scripts now
Diffstat (limited to 'dev-tex/pythontex')
-rw-r--r--dev-tex/pythontex/pythontex-0.12.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-tex/pythontex/pythontex-0.12.ebuild b/dev-tex/pythontex/pythontex-0.12.ebuild
index 76d451f9f..614eee74a 100644
--- a/dev-tex/pythontex/pythontex-0.12.ebuild
+++ b/dev-tex/pythontex/pythontex-0.12.ebuild
@@ -31,16 +31,27 @@ src_prepare() {
src_compile() {
ebegin "Compiling ${PN}"
- python_optimize .
- python_fix_shebang .
latex ${PN}.ins extra >/dev/null || die "Building style from ${PN}.ins failed"
eend
}
src_install() {
- latex-package_src_install
+ python_optimize .
+ python_fix_shebang .
- insinto ${TEXMF}/tex/latex/${PN}
+ if python_is_python3; then
+ python_newscript pythontex3.py pythontex.py
+ python_newscript depythontex3.py depythontex.py
+ fi
+
+ if ! python_is_python3; then
+ python_newscript pythontex2.py pythontex.py
+ python_newscript depythontex2.py depythontex.py
+ python_doscript pythontex_2to3.py
+ fi
+
+ latex-package_src_install
+ #insinto ${TEXMF}/tex/latex/${PN}
dodoc README
}