aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald Weiner <timeraider4u@users.noreply.github.com>2017-03-16 20:34:58 +0100
committerJustin Lecher <jlec@gentoo.org>2017-03-16 19:34:58 +0000
commita250161a0beed34c9af155165faf1b9ed9492283 (patch)
tree718342f6b0798f272d7e95a5906e9b76882d1208 /dev-util/emscripten/emscripten-1.37.3.ebuild
parentsci-libs/dealii: do not compile examples (only source gets installed) (diff)
downloadsci-a250161a0beed34c9af155165faf1b9ed9492283.tar.gz
sci-a250161a0beed34c9af155165faf1b9ed9492283.tar.bz2
sci-a250161a0beed34c9af155165faf1b9ed9492283.zip
dev-util/emscripten: version bump (#756)
Package-manager: portage-2.3.3 repoman-2.3.1
Diffstat (limited to 'dev-util/emscripten/emscripten-1.37.3.ebuild')
-rw-r--r--dev-util/emscripten/emscripten-1.37.3.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-util/emscripten/emscripten-1.37.3.ebuild b/dev-util/emscripten/emscripten-1.37.3.ebuild
deleted file mode 100644
index 51a451856..000000000
--- a/dev-util/emscripten/emscripten-1.37.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="LLVM-to-JavaScript Compiler"
-HOMEPAGE="http://emscripten.org/"
-SRC_URI="https://github.com/kripken/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="UoI-NCSA"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- ~dev-util/emscripten-fastcomp-${PV}"
-RDEPEND="${DEPEND}"
-
-DEST="/usr/share/"
-TEST="${WORKDIR}/test/"
-
-prepare_file() {
- cp "${FILESDIR}/${1}" "${S}/" || die "could not copy '${1}'"
- sed -i "s/\${PV}/${PV}/g" "${S}/${1}" || \
- die "could not adjust path for '${1}'"
-}
-
-src_prepare() {
- prepare_file "99emscripten"
- prepare_file "emscripten.config"
- eapply "${FILESDIR}/${PV}/emcc.patch"
- eapply "${FILESDIR}/${PV}/emcmake.patch"
- eapply_user
-}
-
-src_test() {
- mkdir "${TEST}" || die "Could not create test directory!"
- cp "${FILESDIR}/hello_world.cpp" "${TEST}" || die "Could not copy example file"
- cp "${S}/emscripten.config" "${TEST}" || die "Could not copy config file"
- sed -i -e "/^EMSCRIPTEN_ROOT/s|/usr/share/|${S}|" \
- "${TEST}/emscripten.config" || die "Could not adjust path for testing"
- export EM_CONFIG="${TEST}/emscripten.config" || die "Could not export variable"
- ../"${P}/emcc" "${TEST}/hello_world.cpp" -o "${TEST}/hello_world.js" || \
- die "Error during executing emcc!"
- test -f "${TEST}/hello_world.js" || die "Could not find '${TEST}/hello_world.js'"
- OUT=$(/usr/bin/node "${TEST}/hello_world.js") || \
- die "Could not execute /usr/bin/node"
- EXP=$(echo -e -n 'Hello World!\n') || die "Could not create expected string"
- if [ "${OUT}" != "${EXP}" ]; then
- die "Expected '${EXP}' but got '${OUT}'!"
- fi
- rm -r "${TEST}" || die "Could not clean-up '${TEST}'"
-}
-
-src_install() {
- dodir ${DEST}/${P}
- cp -R "${S}/" "${D}/${DEST}" || die "Could not install files"
- dosym ../share/${P}/emcc /usr/bin/emcc
- dosym ../share/${P}/emcmake /usr/bin/emcmake
- doenvd 99emscripten
- ewarn "If you consider using emscripten in an active shell,"\
- "please execute 'source /etc/profile'"
-}
-
-pkg_postinst() {
- elog "Running emscripten initialization, may take a few seconds..."
- export EM_CONFIG="${DEST}/${P}/emscripten.config" || die "Could not export variable"
- /usr/bin/emcc -v || die "Could not run emcc initialization"
-}