aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-14 15:45:14 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-07-14 15:45:14 -0600
commit2215c2d2a12d1558773ec7379568d95882f97dae (patch)
treedcc81e23a7d2223fa47513a8025f4b077038cc3a /dev-util/f90cache/f90cache-0.93.7.ebuild
parentsci-libs/mumps: fix underlinking for sequential library (diff)
downloadsci-2215c2d2a12d1558773ec7379568d95882f97dae.tar.gz
sci-2215c2d2a12d1558773ec7379568d95882f97dae.tar.bz2
sci-2215c2d2a12d1558773ec7379568d95882f97dae.zip
initial commit
(Portage version: 2.2.0_alpha118/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-util/f90cache/f90cache-0.93.7.ebuild')
-rw-r--r--dev-util/f90cache/f90cache-0.93.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/f90cache/f90cache-0.93.7.ebuild b/dev-util/f90cache/f90cache-0.93.7.ebuild
new file mode 100644
index 000000000..443ad58bc
--- /dev/null
+++ b/dev-util/f90cache/f90cache-0.93.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.7.ebuild,v 1.9 2012/07/01 16:39:59 armin76 Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="a compiler cache for fortran"
+HOMEPAGE="http://people.irisa.fr/Edouard.Canot/f90cache/"
+SRC_URI="http://people.irisa.fr/Edouard.Canot/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/fortran"
+RDEPEND="${DEPEND}
+ dev-util/ccache"
+
+src_prepare() {
+ sed -i -e '/^CFLAGS/d' -e 's/CFLAGS/LDFLAGS/' Makefile.in || die
+}
+
+src_install() {
+ #make install does too much magic
+ dodoc README CHANGES
+ doman f90cache.1
+ dohtml web/*
+ dobin f90cache
+
+ #we depend on ccache, put links in there so that portage uses them
+ #TODO improve this
+ dosym "/usr/bin/f90cache" "${ROOT}/usr/$(get_libdir)/ccache/bin/gfortran"
+}
+
+pkg_postinst() {
+ elog "Please add F90CACHE_DIR=\"${ROOT%/}/var/tmp/f90cache\""
+ elog "to your make.conf otherwise f90cache files end up in"
+ elog "home of the user executing portage"
+}