aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2017-04-11 20:19:09 -0600
committerChristoph Junghans <ottxor@gentoo.org>2017-04-11 20:19:27 -0600
commite91665803f697f31dc3b36b90ad20a3c9320c67c (patch)
tree8504754d385eb2c920f78d4479dd5dc8c3d65a2b /dev-util/f90cache/f90cache-0.99.ebuild
parentsci-libs/arrayfire: Apply upstream patch to 3.4.2 (diff)
downloadsci-e91665803f697f31dc3b36b90ad20a3c9320c67c.tar.gz
sci-e91665803f697f31dc3b36b90ad20a3c9320c67c.tar.bz2
sci-e91665803f697f31dc3b36b90ad20a3c9320c67c.zip
dev-util/f90cache: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/f90cache/f90cache-0.99.ebuild')
-rw-r--r--dev-util/f90cache/f90cache-0.99.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/f90cache/f90cache-0.99.ebuild b/dev-util/f90cache/f90cache-0.99.ebuild
new file mode 100644
index 000000000..6012e0ae6
--- /dev/null
+++ b/dev-util/f90cache/f90cache-0.99.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="a compiler cache for fortran"
+HOMEPAGE="http://people.irisa.fr/Edouard.Canot/f90cache/"
+SRC_URI="http://people.irisa.fr/Edouard.Canot/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-util/ccache"
+
+src_prepare() {
+ default
+ sed -i -e '/OBJS/s/CFLAGS/LDFLAGS/' -e '/strip/d' Makefile.in || die
+}
+
+src_install() {
+ default
+
+ #we depend on ccache, put links in there so that portage find it
+ #TODO improve this
+ dosym "/usr/bin/f90cache" "${ROOT}/usr/$(get_libdir)/ccache/bin/gfortran"
+}
+
+pkg_postinst() {
+ elog "Please add F90CACHE_DIR=\"${ROOT%/}/var/tmp/f90cache\""
+ elog "to your make.conf otherwise f90cache files end up in"
+ elog "home of the user executing portage"
+}