aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-28 17:45:50 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-08-28 17:46:04 +0200
commita00807eca5721b59b505c43549ea6c5ea2d406b1 (patch)
tree5ece8ef42522c5ae06711b825f3f21dccd62fe0c /dev-util/smartgit
parentlincense smartgit added (diff)
downloadsci-a00807eca5721b59b505c43549ea6c5ea2d406b1.tar.gz
sci-a00807eca5721b59b505c43549ea6c5ea2d406b1.tar.bz2
sci-a00807eca5721b59b505c43549ea6c5ea2d406b1.zip
smartgit added
Diffstat (limited to 'dev-util/smartgit')
-rw-r--r--dev-util/smartgit/ChangeLog10
-rw-r--r--dev-util/smartgit/Manifest4
-rw-r--r--dev-util/smartgit/metadata.xml6
-rw-r--r--dev-util/smartgit/smartgit-0_alpha1_rc3.ebuild44
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/smartgit/ChangeLog b/dev-util/smartgit/ChangeLog
new file mode 100644
index 000000000..f3bf24a28
--- /dev/null
+++ b/dev-util/smartgit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/smartgit
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*smartgit-0_alpha1_rc3 (28 Aug 2009)
+
+ 28 Aug 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +smartgit-0_alpha1_rc3.ebuild, +metadata.xml:
+ Adopted from smartsvn ebuild in sunrise
+
diff --git a/dev-util/smartgit/Manifest b/dev-util/smartgit/Manifest
new file mode 100644
index 000000000..d8c21e4ff
--- /dev/null
+++ b/dev-util/smartgit/Manifest
@@ -0,0 +1,4 @@
+DIST smartgit-generic-M1-build-3.tar.gz 4067634 RMD160 dad98290507b95cb58ea33930f82e0fa72669502 SHA1 2cedc114903b6df640ce4dcfc67a519ad853f6fe SHA256 748a7d368a664b92e4a7b313bf050b6760c169e05e473a21c46dd25ca27d8745
+EBUILD smartgit-0_alpha1_rc3.ebuild 1054 RMD160 0cc380aeb5e2fbbd76be76d9b13a141d8007ea13 SHA1 7a3d012f36452c7b18826a5b2726349d2639b51b SHA256 b260ec1db7d6d9dec3e5b0e8b706d48f781957b0645b25eeb282b8a023e11711
+MISC ChangeLog 304 RMD160 043b653b2a6aed3b5479cbdb070bb90b5fc1ec05 SHA1 fb16a8e1c28464b9bfba2a65d635e7dd8c43f0f8 SHA256 242a23a6b6b164b778211ee8670a55d24007f58640dae2c5993ec052e4677d56
+MISC metadata.xml 263 RMD160 29af7f646812a941362d89c0ee9566150df25b5b SHA1 8d5988faa6a2e1b34ca739895d1b425ddafcb32e SHA256 1a4b794f9b03c548e77abf998b34c58b16e852d255bf0322f34b48554c003c30
diff --git a/dev-util/smartgit/metadata.xml b/dev-util/smartgit/metadata.xml
new file mode 100644
index 000000000..ede0c5e35
--- /dev/null
+++ b/dev-util/smartgit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>SmartSVN is a powerful GUI SVN client written in Java</longdescription>
+</pkgmetadata>
diff --git a/dev-util/smartgit/smartgit-0_alpha1_rc3.ebuild b/dev-util/smartgit/smartgit-0_alpha1_rc3.ebuild
new file mode 100644
index 000000000..79f58d6b4
--- /dev/null
+++ b/dev-util/smartgit/smartgit-0_alpha1_rc3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-utils-2
+
+DESCRIPTION="SmartGIT"
+HOMEPAGE="http://www.syntevo.com/smartgit"
+SRC_URI="${PN}-generic-M1-build-3.tar.gz"
+
+SLOT="0"
+LICENSE="smartgit"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}"/smartgit-M1-build-3/
+
+pkg_nofetch(){
+ einfo "Please download ${MY_P}.tar.gz from:"
+ einfo "${HOMEPAGE}download.html?file=smartsvn/${MY_P}.tar.gz"
+ einfo "and move/copy to ${DISTDIR}"
+}
+
+src_install() {
+ local rdir="/opt/${PN}"
+ insinto ${rdir}
+ doins -r * || die "cannot install needed files"
+
+ java-pkg_regjar "${D}"/${rdir}/lib/*.jar
+
+ java-pkg_dolauncher ${PN} --java_args "-Xmx256M -Dsmartgit.vm-xmx=256m" --jar ${PN}.jar
+
+ for X in 32 64 128
+ do
+ insinto /usr/share/icons/hicolor/${X}x${X}/apps
+ newins "${S}/bin/${PN}-${X}x${X}.png" "${PN}.png" || die "cannot install needed files"
+ done
+
+ make_desktop_entry "${PN}" "SmartGIT" ${PN}.png "Development;RevisionControl"
+}